summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-03-02 22:34:31 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-03-02 22:34:40 +0000
commit4eaa82558651cbe073c5d522c1415d1238952c45 (patch)
treec4b6d7337a0f6f6e188f2aa5a17c25a8357cf664
parentnet-analyzer/nsat: Remove libtirpc automagic and depend on it instead (diff)
downloadgentoo-4eaa8255.tar.gz
gentoo-4eaa8255.tar.bz2
gentoo-4eaa8255.zip
sys-devel/crossdev: bump up to 20180302, bug #589672
Bug: https://bugs.gentoo.org/589672 Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20180302.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 28c9949fc061..54e0a8d30cac 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,3 +1,4 @@
DIST crossdev-20171230.tar.xz 23016 BLAKE2B 4661b3f9fac314b7346f0de7227d12ae2d6851e448f6d065471499df8ada5d699ef91c6b6bca285b2aefcbf67ab351fefbe9344c0884a7c0d33ff27215c8ed9c SHA512 bf8761a3018790501adb4bb173e3281d1d7628de8f65a1aa5df0b328a4af8088be466dbe8c185e7ed44aca31b078320a4f62c56351f4b7cbf832349184d9709f
DIST crossdev-20180105.tar.xz 23056 BLAKE2B 66618f312b6f9492b1ccbdc7142e6b38035bb52f864a53d5b6afed702f31dcad11d647af68239dd6cb1af06b7eee5046507cffb03aabb27f758d0513ae9aa888 SHA512 f10ac454a996268e0bf798e2e322961873f3666c032f0ea3a0bc88eabd0428d894726726b089ca180ff9b718b5041be136c28a572ffb31fde76b8ac58a8fc1f2
DIST crossdev-20180120.tar.xz 23328 BLAKE2B a95b834f2b5c0cfad178a2795ec650c2461c6462f4aad239e55666f4503e2607410d5fb318a2fa59d01271475e6d4438ca399ad6565632610ad51ae0142ea5c0 SHA512 7b57f4eebec3ddf6460fb3305a124c670c79d6d4708e45314fd4e68b47bfdc9617f2dbd8c1c30af141fe43d4afc001615b1574e155fb5685c703f5e17149c3ba
+DIST crossdev-20180302.tar.xz 23368 BLAKE2B 1bd93ca8dc1c65d1c5cbc095a84540e0a09f666674d87e56ff051900e1f3ab60a087a61734c86406d3f8160469c20e161b940ca19b1f4da318461d02d7915ac3 SHA512 f1b5d066851c54e84c1bb58f261655be2e5ac4c7a247831f4c45186574a306e839497b5a72cf9d603545c01b52ef3ee47b6c7c90086217268572697835fc7f1e
diff --git a/sys-devel/crossdev/crossdev-20180302.ebuild b/sys-devel/crossdev/crossdev-20180302.ebuild
new file mode 100644
index 000000000000..edf23ce34c9b
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20180302.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED%/}"/usr/bin/crossdev || die
+ fi
+}