summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:11:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:12:05 +0300
commit4eb6e7012cb44a06ca67486124aff6ec59e0f6f7 (patch)
tree08c8d17e92c44f4e52c195a81d55824d2b1bd17a
parentdev-python/pytest-shell-utilities: enable py3.11 (diff)
downloadgentoo-4eb6e701.tar.gz
gentoo-4eb6e701.tar.bz2
gentoo-4eb6e701.zip
dev-python/werkzeug: add 2.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 1eca60fcf8c3..e1aff198a676 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1,2 +1,3 @@
DIST werkzeug-2.1.2.gh.tar.gz 833667 BLAKE2B e045f566862bfe0f86185cd10aa26bf94a4fc2f7b23173c6a28c9b55d0f239fbba5c66071fab5df6102717b51a1c1fada872e9d9383b9d3b34ab92ffcfd96e59 SHA512 28c4a794a3dbc8423e59244fbcf192b60b53f378444aaaf60330bdd62cec38a4625033b5d72b55613c8b26053a60153ddcb816331ff28ad3ee03bede74d8b1b3
DIST werkzeug-2.2.0.gh.tar.gz 839619 BLAKE2B b6eae91d9a44d030517be5da13c448cf4a2778db7cde61ce36add8dea6f2ac251b31e71d128c4156f44083a4c1b77e546a7e6c55787d8beb93c49538d45b51fd SHA512 2de05269ccd3d83728d435d2f155887a5fd3f3bda9b71c32ffd64b089116c80e89319870fa082f1c6feeeb797b665521b9692ce6c87dcb48b7fa49b2fc63516b
+DIST werkzeug-2.2.1.gh.tar.gz 840062 BLAKE2B da7c59eb182e2318c291a6d346a2a444cc054726dd3cf47617b82440383a4c1068b4a31adb6f44d1b965e2efbacf7469c1845d3666fe24288e976bc25794ebcf SHA512 466d164f8a5861cd36eaaf3674a8bb6640593981007d1d6bced1abbdaf8c6a39666601960ebfb2dc35b7c9c17a961ea07bf919cd646c282d27fd5e0f36cc3035
diff --git a/dev-python/werkzeug/werkzeug-2.2.1.ebuild b/dev-python/werkzeug/werkzeug-2.2.1.ebuild
new file mode 100644
index 000000000000..8024b1a6cdd0
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ $(python_gen_cond_dep '
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ' python3_{8..11} pypy3 # TODO: add py3.11 when ported
+ )
+ ) ) )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}