summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-26 12:43:14 +0100
committerSebastian Pipping <sping@gentoo.org>2015-12-05 00:03:07 +0100
commit4ebc9d32ff5f11ede606c04298d88f1199993cd6 (patch)
treebf1ab9cf4479ef7f83198161ec3db53c35ac8e4a
parentdev-java/stringtemplate: Remove old (diff)
downloadgentoo-4ebc9d32.tar.gz
gentoo-4ebc9d32.tar.bz2
gentoo-4ebc9d32.zip
media-libs/babl: version bump to 0.1.14
Package-Manager: portage-2.2.25 RepoMan-Options: --force
-rw-r--r--media-libs/babl/Manifest1
-rw-r--r--media-libs/babl/babl-0.1.14.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-libs/babl/Manifest b/media-libs/babl/Manifest
index b8463b932da6..e0313e5f2055 100644
--- a/media-libs/babl/Manifest
+++ b/media-libs/babl/Manifest
@@ -1,2 +1,3 @@
DIST babl-0.1.10.tar.bz2 449537 SHA256 943fc36ceac7dd25bc928256bc7b535a42989c6b971578146869eee5fe5955f4 SHA512 2950d94c255ee05d405e003a46138da0f4e0cad65e2d2a882089b788c2deac0524014f7c5758c3097253bdbebaded433caf0447c7d218c9cc96798df9e6f0c92 WHIRLPOOL a71907a531bc71c7ac0c84a197a559c50321a5d96b5d846083935390890ef116780d49bd458577aef0e948395dc14897e6fbbc75478b2a59d57d4381cf7f8db8
DIST babl-0.1.12.tar.bz2 642234 SHA256 2f802b7f1a17b72c10bf0fe1e69b7a888cf7ce62b7cf1537b030f7f88d55a407 SHA512 b69c8e3870f25372b2223aa4a716383af30342822461fc847039af964cdd194603dbc327a5c3547369d64b206b54280a5a9a227197ca6b7bcfbfa8e2e560df6a WHIRLPOOL b1a170492f1c1e6f030f418cc66c3be02cd2bd7e10896a416b5feaf2d7aa82de4fa15c9d2a65e6e1038ab6822e4dc3333f96102e18d757a6b1e07f4017b4beba
+DIST babl-0.1.14.tar.bz2 718238 SHA256 e6dcb112c8f8f75471823fdcc5a6a65f753b4d0e96e377979ea01a5d6fad7d4f SHA512 fb7c48738b968c2cf01aab20b50c7768501b73c8c34957ef500cf7a77bb2dce519ede34463a8a100037533d5f3566e1cd23d898c41eb29fc01620a0dde131398 WHIRLPOOL e85a868e751f490a9dee002bd93214033f0fbaab7dbd65c0062c55f98af810be83e6899804bdd2c4e45f2625f2e75a36784890c950e34b35baf0104c69bd2a79
diff --git a/media-libs/babl/babl-0.1.14.ebuild b/media-libs/babl/babl-0.1.14.ebuild
new file mode 100644
index 000000000000..ce739efbe576
--- /dev/null
+++ b/media-libs/babl/babl-0.1.14.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.gnome.org/babl"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="altivec cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_mmx"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+ [[ ${PV} == *9999* ]] && eautoreconf
+}
+
+src_configure() {
+ # Automagic rsvg support is just for website generation we do not call,
+ # so we don't need to fix it
+ # w3m is used for dist target thus no issue for us that it is automagically
+ # detected
+ econf \
+ --disable-docs \
+ --disable-static \
+ --disable-maintainer-mode \
+ $(use_enable altivec) \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse sse2)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}