summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-04 06:14:27 +0100
committerSam James <sam@gentoo.org>2023-06-04 06:14:27 +0100
commit4ec05bb11baf32b0a53cd3833c7ed448418d618c (patch)
treeb253b2d97eee7fb319af76b748f93f7624cc434f
parentsys-cluster/ceph: fix parallel(?) build failure (diff)
downloadgentoo-4ec05bb11baf32b0a53cd3833c7ed448418d618c.tar.gz
gentoo-4ec05bb11baf32b0a53cd3833c7ed448418d618c.tar.bz2
gentoo-4ec05bb11baf32b0a53cd3833c7ed448418d618c.zip
dev-util/git-delta: add 0.16.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/git-delta/Manifest1
-rw-r--r--dev-util/git-delta/git-delta-0.16.5.ebuild238
2 files changed, 239 insertions, 0 deletions
diff --git a/dev-util/git-delta/Manifest b/dev-util/git-delta/Manifest
index 54789a7a5caf..0e0c27753ade 100644
--- a/dev-util/git-delta/Manifest
+++ b/dev-util/git-delta/Manifest
@@ -100,6 +100,7 @@ DIST getrandom-0.2.3.crate 26261 BLAKE2B 3e52a87b9355f850e07e5080c20e1ab3acfa927
DIST getrandom-0.2.8.crate 30553 BLAKE2B 30211bc6a8ceb5ba765cbf068405cfc08842b2521c5850647971f4cb4bc9a5b0a9195ccfbc1461de019eeb7744ee69f934922ff21677259d7b815800516df4dc SHA512 cd7aea29f79a33a0de2a52a0a82f2b57ea8f27908ccfe00a5f42248766df88b225023603ec56d6fc634ef9c1eb67ad0135c90d4c695f6f659db0767e7fda44c5
DIST git-delta-0.15.1.tar.gz 499576 BLAKE2B b29972e8fb1e640ced5f8148610a17177e08cda2988189bd3cad585937c85b8b749cf3e3fd4648599462b4272d4f3b99448cead13a688289732106e744a294d5 SHA512 646244299ec79d59ff91fd0b2d9600795a6c0e4f3f6efa6629217a6847d6b736ceed45bd52435aeb25cd80ffa9630bf9cebce35312fead3de2bb5b0d04e790c4
DIST git-delta-0.16.4.tar.gz 506782 BLAKE2B 6926544e973c00853359f1870ae1e38e8fb4cc7bc217f15fb68dc96ee6de2d70b45aa8fd054c07aa126db427d1a8e4af4bfef10dda05fb5ccf56a623af4e1ed9 SHA512 9052d5db95e2977844581d8d7027c0e9c16c407120d74fc0e72b47db003424add49620dcaaf7ccd686a788187ce277568491bd6e9300c867da208d50387dbad8
+DIST git-delta-0.16.5.tar.gz 506739 BLAKE2B 28e88c84fc299c3b148eb71bcc3de26dfc5d52140e79d188d71d2a8c902485e06ed62c09826cdf22c7d97f6aeab42e5c39d09b26aac49afcacf4cecd0c690ff3 SHA512 76475159ad659261dea3f60e5ee340d64f16031b59387602a6b962f854e5c88e5ad1613715ea0581197d8b829c75326d25c9550d0899957a0ce7e4dd5d3046a9
DIST git2-0.14.2.crate 196856 BLAKE2B 09ed89e5eaf632b1bd9c33ff7afff78808599823804668cb6f85925a8d61359300b460db8b34e6562b8289b79b53094df4c184e013a8d4d4b58c510447fd0ec8 SHA512 7e4c0660fb7f48fda3ed73bcd577e2a40eb44005bd1130f9fbc0c515bfd155ec75a2efabdde99661a7c4590e52a749be4342397b79a47bbfe8f4fb8fe160dd22
DIST git2-0.16.1.crate 199956 BLAKE2B bf187855d683b13ec8ec0e103f6536fc2d8321d2a023eebca907a15f0bba760f833cce4a4b0958804675aeae1ee9d2dc0270edf02c66cc2d7231980ba7ab15d1 SHA512 4963798b6d9fc087a4394515b0f6da0a9e01fcbc220dc3d1880a277ea0487083ac05c0bc3a52a537885eb065a9b2209658a199835457b38c94e45395ad8d6252
DIST globset-0.4.10.crate 22923 BLAKE2B 10bb8db9ceae039143e36c2f1c3cef92848277ae7b4bff6669f1c25aeb3ae1d322da7d88ec13cf9b0ba5edc0e27a52843a5672a8dac225d3c37bc1785c04e6fe SHA512 85a1213fd3ec55ffd87fde25f4cdbd2e8ed4056132d3c516eb117f107a744d733e1ad8fa06f296a60084a23ee968c3c0899399fd3ab9bbf72e217638a5cf165e
diff --git a/dev-util/git-delta/git-delta-0.16.5.ebuild b/dev-util/git-delta/git-delta-0.16.5.ebuild
new file mode 100644
index 000000000000..d1eb8ae038ca
--- /dev/null
+++ b/dev-util/git-delta/git-delta-0.16.5.ebuild
@@ -0,0 +1,238 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ adler-1.0.2
+ aho-corasick-0.7.20
+ android_system_properties-0.1.5
+ ansi_colours-1.2.1
+ ansi_term-0.12.1
+ anyhow-1.0.70
+ approx-0.5.1
+ arrayvec-0.7.2
+ atty-0.2.14
+ autocfg-1.1.0
+ base64-0.21.0
+ bat-0.22.1
+ bincode-1.3.3
+ bitflags-1.3.2
+ bitflags-2.2.1
+ box_drawing-0.1.2
+ bstr-1.3.0
+ bumpalo-3.12.0
+ bytelines-2.2.2
+ bytemuck-1.13.1
+ bytesize-1.2.0
+ cc-1.0.79
+ cfg-if-1.0.0
+ chrono-0.4.23
+ chrono-humanize-0.2.2
+ clap-4.1.8
+ clap_derive-4.1.8
+ clap_lex-0.3.2
+ clircle-0.3.0
+ codespan-reporting-0.11.1
+ console-0.15.5
+ content_inspector-0.2.4
+ core-foundation-sys-0.8.3
+ crc32fast-1.3.2
+ ctrlc-3.2.5
+ cxx-1.0.91
+ cxx-build-1.0.91
+ cxxbridge-flags-1.0.91
+ cxxbridge-macro-1.0.91
+ dirs-4.0.0
+ dirs-sys-0.3.7
+ either-1.8.1
+ encode_unicode-0.3.6
+ encoding-0.2.33
+ encoding-index-japanese-1.20141219.5
+ encoding-index-korean-1.20141219.5
+ encoding-index-simpchinese-1.20141219.5
+ encoding-index-singlebyte-1.20141219.5
+ encoding-index-tradchinese-1.20141219.5
+ encoding_index_tests-0.1.4
+ errno-0.2.8
+ errno-dragonfly-0.1.2
+ find-crate-0.6.3
+ flate2-1.0.25
+ fnv-1.0.7
+ form_urlencoded-1.1.0
+ getrandom-0.2.8
+ git2-0.16.1
+ globset-0.4.10
+ grep-cli-0.1.7
+ hashbrown-0.12.3
+ heck-0.4.1
+ hermit-abi-0.1.19
+ hermit-abi-0.3.1
+ iana-time-zone-0.1.53
+ iana-time-zone-haiku-0.1.1
+ idna-0.3.0
+ indexmap-1.9.2
+ io-lifetimes-1.0.5
+ is-terminal-0.4.4
+ itertools-0.10.5
+ itoa-1.0.6
+ jobserver-0.1.26
+ js-sys-0.3.61
+ lazy_static-1.4.0
+ libc-0.2.139
+ libgit2-sys-0.14.2+1.5.1
+ libz-sys-1.1.8
+ line-wrap-0.1.1
+ link-cplusplus-1.0.8
+ linked-hash-map-0.5.6
+ linux-raw-sys-0.1.4
+ log-0.4.17
+ memchr-2.5.0
+ miniz_oxide-0.6.2
+ nix-0.26.2
+ ntapi-0.4.0
+ num-integer-0.1.45
+ num-traits-0.2.15
+ once_cell-1.17.1
+ onig-6.4.0
+ onig_sys-69.8.1
+ os_str_bytes-6.4.1
+ palette-0.6.1
+ palette_derive-0.6.1
+ path_abs-0.5.1
+ pathdiff-0.2.1
+ percent-encoding-2.2.0
+ phf-0.11.1
+ phf_generator-0.11.1
+ phf_macros-0.11.1
+ phf_shared-0.11.1
+ pkg-config-0.3.26
+ plist-1.4.1
+ proc-macro-error-1.0.4
+ proc-macro-error-attr-1.0.4
+ proc-macro2-1.0.51
+ quick-xml-0.26.0
+ quote-1.0.23
+ rand-0.8.5
+ rand_core-0.6.4
+ redox_syscall-0.2.16
+ redox_users-0.4.3
+ regex-1.7.1
+ regex-automata-0.1.10
+ regex-syntax-0.6.28
+ rgb-0.8.36
+ rustix-0.36.9
+ ryu-1.0.13
+ safemem-0.3.3
+ same-file-1.0.6
+ scratch-1.0.4
+ semver-1.0.16
+ serde-1.0.152
+ serde_derive-1.0.152
+ serde_json-1.0.93
+ serde_yaml-0.8.26
+ shell-words-1.1.0
+ siphasher-0.3.10
+ smol_str-0.1.24
+ static_assertions-1.1.0
+ std_prelude-0.2.12
+ strsim-0.10.0
+ syn-1.0.109
+ syntect-5.0.0
+ sysinfo-0.28.2
+ termcolor-1.2.0
+ terminal_size-0.2.5
+ thiserror-1.0.38
+ thiserror-impl-1.0.38
+ time-0.1.45
+ time-0.3.20
+ time-core-0.1.0
+ time-macros-0.2.8
+ tinyvec-1.6.0
+ tinyvec_macros-0.1.1
+ toml-0.5.11
+ unicode-bidi-0.3.10
+ unicode-ident-1.0.7
+ unicode-normalization-0.1.22
+ unicode-segmentation-1.10.1
+ unicode-width-0.1.10
+ url-2.3.1
+ utf8parse-0.2.0
+ vcpkg-0.2.15
+ version_check-0.9.4
+ vte-0.11.0
+ vte_generate_state_changes-0.1.1
+ walkdir-2.3.2
+ wasi-0.10.0+wasi-snapshot-preview1
+ wasi-0.11.0+wasi-snapshot-preview1
+ wasm-bindgen-0.2.84
+ wasm-bindgen-backend-0.2.84
+ wasm-bindgen-macro-0.2.84
+ wasm-bindgen-macro-support-0.2.84
+ wasm-bindgen-shared-0.2.84
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-sys-0.42.0
+ windows-sys-0.45.0
+ windows-targets-0.42.1
+ windows_aarch64_gnullvm-0.42.1
+ windows_aarch64_msvc-0.42.1
+ windows_i686_gnu-0.42.1
+ windows_i686_msvc-0.42.1
+ windows_x86_64_gnu-0.42.1
+ windows_x86_64_gnullvm-0.42.1
+ windows_x86_64_msvc-0.42.1
+ xdg-2.4.1
+ yaml-rust-0.4.5
+"
+
+inherit bash-completion-r1 cargo
+
+DESCRIPTION="A syntax-highlighting pager for git"
+HOMEPAGE="https://github.com/dandavison/delta"
+SRC_URI="https://github.com/dandavison/delta/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" $(cargo_crate_uris ${CRATES})"
+S="${WORKDIR}/${P/git-/}"
+
+LICENSE="MIT"
+# Dependent crate licenses
+LICENSE+=" Apache-2.0 CC0-1.0 LGPL-3+ MIT Unicode-DFS-2016"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ dev-libs/libgit2:=
+ dev-libs/oniguruma:=
+"
+RDEPEND="
+ ${DEPEND}
+ !app-text/delta
+"
+
+QA_FLAGS_IGNORED="usr/bin/delta"
+
+src_configure() {
+ # Some crates will auto-build and statically link C libraries(!)
+ # Tracker bug #709568
+ export RUSTONIG_SYSTEM_LIBONIG=1
+ export LIBGIT2_SYS_USE_PKG_CONFIG=1
+ export PKG_CONFIG_ALLOW_CROSS=1
+}
+
+src_install() {
+ cargo_src_install
+
+ # No man page (yet?)
+
+ # Completions
+ newbashcomp "${S}"/etc/completion/completion.bash delta
+
+ insinto /usr/share/zsh/site-functions
+ newins "${S}"/etc/completion/completion.zsh _delta
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins "${S}"/etc/completion/completion.fish
+}