summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-14 01:20:37 +0100
committerSam James <sam@gentoo.org>2022-09-14 01:20:37 +0100
commit4ed80e7fbd76241d440fe0bcd84d8723f93b8d73 (patch)
tree2ea5ef29495e49fa6e50096e8dad1f5616155494
parentnet-libs/rpcsvc-proto: fix cpp call (diff)
downloadgentoo-4ed80e7fbd76241d440fe0bcd84d8723f93b8d73.tar.gz
gentoo-4ed80e7fbd76241d440fe0bcd84d8723f93b8d73.tar.bz2
gentoo-4ed80e7fbd76241d440fe0bcd84d8723f93b8d73.zip
dev-util/colm: respect CC
Fixes build on pure Clang systems. There's a proper upstream fix [0] but it's too awkward to backport with our other patches and there's been a lot of other changes relating to our patches upstream anyway. Have asked for a new release. [0] https://github.com/adrian-thurston/colm/commit/bb487b1368b65a1f30fe3a59fd0c7d84bdcc483b. Closes: https://bugs.gentoo.org/771849 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/colm/colm-0.14.7-r1.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-util/colm/colm-0.14.7-r1.ebuild b/dev-util/colm/colm-0.14.7-r1.ebuild
index 59000e4847fa..147625389f13 100644
--- a/dev-util/colm/colm-0.14.7-r1.ebuild
+++ b/dev-util/colm/colm-0.14.7-r1.ebuild
@@ -36,6 +36,7 @@ src_prepare() {
sed -i -e 's/(\[ASCIIDOC\], \[asciidoc\], \[asciidoc\]/S([ASCIIDOC], [asciidoc asciidoctor]/' configure.ac || die
# bug #766069
+ sed -i -e "s:gcc:$(tc-getCC) ${CFLAGS}:" src/main.cc || die
sed -i -e "s:gcc:$(tc-getCC):" test/colm.d/gentests.sh || die
sed -i -e "s:g++:$(tc-getCXX):" test/colm.d/gentests.sh || die