summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-21 20:47:51 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-21 21:08:51 +0200
commit4eddc8adbd1f731259b52b2d66ae44ad4af3b513 (patch)
tree6f6361d28f4e47b83f3fc11d48de20723e30008f
parentlxqt-base/lxqt-globalkeys: version bump to 1.0.1 (diff)
downloadgentoo-4eddc8ad.tar.gz
gentoo-4eddc8ad.tar.bz2
gentoo-4eddc8ad.zip
dev-python/berkeleydb: add 18.1.5
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/berkeleydb/Manifest1
-rw-r--r--dev-python/berkeleydb/berkeleydb-18.1.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/berkeleydb/Manifest b/dev-python/berkeleydb/Manifest
index 486f8088b1e8..4807bdfcebfb 100644
--- a/dev-python/berkeleydb/Manifest
+++ b/dev-python/berkeleydb/Manifest
@@ -1 +1,2 @@
DIST berkeleydb-18.1.4.tar.xz 137160 BLAKE2B c93e7707bf12199c8161112accfedc3b0180b8f6edcf5c928c03f373528bb9ccb23219865344d9ed29d30b0133a2161ba0325257b6f7a2d22a58e8d9b1f82ce2 SHA512 bac2848e82ba5fdd3ca8fbf3a02d04faf270132f4b9fe93096ea57ab99fcc7eba02ff8a9638ea8e028d8bd4f16eebbefb65f33ea67e95c0a14cced05d04b23b8
+DIST berkeleydb-18.1.5.tar.xz 138488 BLAKE2B 1131509f30316469cfed30abdbd672ab73ef7dfc957e16935d04066b4a2efeb3c777ae4f70f821a29f4d8b8b51d649998735eb412639cc52997c9ee4a98c51db SHA512 c7a51e96cf32b74188b0cb4ed1d8b87436b30dc4929ba22180677ffb5eacd455a67eb5a231c814fc46ccc4c6a5da2f41876a343228969eab988bb0766d40a751
diff --git a/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild b/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild
new file mode 100644
index 000000000000..1117442721e8
--- /dev/null
+++ b/dev-python/berkeleydb/berkeleydb-18.1.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit db-use distutils-r1
+
+# Tests aren't included in PyPi tarballs, so just manually clone from upstream
+# at https://hg.jcea.es/pybsddb/ and prepare out tarball
+
+DESCRIPTION="Python bindings for Oracle Berkeley DB"
+HOMEPAGE="https://www.jcea.es/programacion/pybsddb.htm https://pypi.org/project/berkeleydb/"
+SRC_URI="https://dev.gentoo.org/~arthurzam/distfiles/dev-python/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ || (
+ sys-libs/db:6.2
+ sys-libs/db:5.3
+ sys-libs/db:4.8
+ )"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # This list should be kept in sync with setup3.py.
+ if [[ -z ${DB_VER} ]]; then
+ for DB_VER in 6.2 5.3 4.8; do
+ has_version "sys-libs/db:${DB_VER}" && break
+ done
+ fi
+
+ # Force version.
+ sed -e "s/db_ver = None/db_ver = (${DB_VER%.*}, ${DB_VER#*.})/" \
+ -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
+ -i setup3.py || die
+
+ # rename to bypass name conflict with builtin test module
+ mv test.py test3.py || die
+
+ # Adjust test3.py to look in build/lib.
+ sed -e "s/'lib.%s' % PLAT_SPEC/'lib'/" -i test3.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # These are needed for both build and install.
+ export BERKELEYDB_DIR="${EPREFIX}/usr"
+ export BERKELEYDB_INCDIR="$(db_includedir ${DB_VER})"
+ export BERKELEYDB_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ export YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION=1
+}
+
+python_test() {
+ "${EPYTHON}" test3.py -vv || die "Testing failed with ${EPYTHON}"
+}