summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-16 15:57:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-16 16:07:48 +0200
commit4edf40f7c0c92aab27966449e656bff35d257366 (patch)
tree907981463ea78b0fa95503d356775e1ba0395a1a
parentdev-python/psycopg: Add GH remote-id (diff)
downloadgentoo-4edf40f7c0c92aab27966449e656bff35d257366.tar.gz
gentoo-4edf40f7c0c92aab27966449e656bff35d257366.tar.bz2
gentoo-4edf40f7c0c92aab27966449e656bff35d257366.zip
gui-apps/kanshi: add 1.3.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--gui-apps/kanshi/Manifest1
-rw-r--r--gui-apps/kanshi/kanshi-1.3.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gui-apps/kanshi/Manifest b/gui-apps/kanshi/Manifest
index f20c66d2b975..7a8503a271d6 100644
--- a/gui-apps/kanshi/Manifest
+++ b/gui-apps/kanshi/Manifest
@@ -1 +1,2 @@
DIST kanshi-1.3.0.tar.gz 20721 BLAKE2B 56ba2241f21c41c5ba0e33c25ed0fb32ce471ac1c5f8dd030f93cb27e142319d1643143e78d4b375f855af1af5a078168e589ef74c82aaf738cef95618c122ab SHA512 f89164b1c4440d1cb29dfd70aab0721607dd63ea144ace9a2ff30cf89e662d404044bb30a5bc6c5544e8988db498eba3cd80100424ca76d31cc35b60e38036d9
+DIST kanshi-1.3.1.tar.gz 20991 BLAKE2B 9ecad147d2ace82ea4a2e8fccbc1a2a81bdca534f4ae952a1bbc4303c4ff0e6cf6de5dd617e1ee79abd23bb094358b3336bc031748525f628b912e53e5a04db8 SHA512 21580c6d950c33ce80a3d39e71ae8352c23c96d89827b79f4a294ccade87026c1ce294a5f9aa9b58e06f7930a3885ab9a54400b7289dfbee18a2a1a53a55709b
diff --git a/gui-apps/kanshi/kanshi-1.3.1.ebuild b/gui-apps/kanshi/kanshi-1.3.1.ebuild
new file mode 100644
index 000000000000..2f3236686822
--- /dev/null
+++ b/gui-apps/kanshi/kanshi-1.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic display configuration (autorandr for wayland)"
+HOMEPAGE="https://wayland.emersion.fr/kanshi/ https://sr.ht/~emersion/kanshi/"
+SRC_URI="
+ https://git.sr.ht/~emersion/kanshi/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S=${WORKDIR}/${PN}-v${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+man varlink"
+
+RDEPEND="
+ dev-libs/wayland
+ varlink? ( dev-libs/libvarlink )
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+ man? ( >=app-text/scdoc-1.9.3 )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature man man-pages)
+ $(meson_feature varlink ipc)
+ )
+ meson_src_configure
+}