summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-12-04 09:52:52 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-12-04 09:52:52 -0600
commit4ef82b584f403fe13034a4aae1ca410383c980ef (patch)
tree041713a1ad8ce899d049eab319eab46e069d3011
parentsys-apps/systemd: set release mode for live and rc's (diff)
downloadgentoo-4ef82b584f403fe13034a4aae1ca410383c980ef.tar.gz
gentoo-4ef82b584f403fe13034a4aae1ca410383c980ef.tar.bz2
gentoo-4ef82b584f403fe13034a4aae1ca410383c980ef.zip
app-containers/skopeo: drop 1.14.0-r1
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/skopeo/files/makefile-1.14.0.patch38
-rw-r--r--app-containers/skopeo/skopeo-1.14.0-r1.ebuild81
2 files changed, 0 insertions, 119 deletions
diff --git a/app-containers/skopeo/files/makefile-1.14.0.patch b/app-containers/skopeo/files/makefile-1.14.0.patch
deleted file mode 100644
index ee3383925a2b..000000000000
--- a/app-containers/skopeo/files/makefile-1.14.0.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-# Patch by Rahil Bhimjiani (IRC: rahilarious) (rahil3108@gmail.com)
-#
-# Rationale behind this patch:
-# 1. We don't install these files (policy.json default.yaml) as part of skopeo because podman, buildah, et. al need them as well, and there's no need for those to depend on skopeo just for configuration. Rely on app-containers/containers-common which has them split out instead. See https://bugs.gentoo.org/849863
-# 2. Remove install-*: because it tries to (re)compile stuff (which we already built in src_compile) on install commands. src_install should only install, not compile
-#
-#
---- a/Makefile
-+++ b/Makefile
-@@ -158,23 +158,20 @@
- rm -rf bin docs/*.1 completions/
-
- install: install-binary install-docs install-completions
-- install -d -m 755 ${DESTDIR}${LOOKASIDEDIR}
- install -d -m 755 ${DESTDIR}${CONTAINERSCONFDIR}
-- install -m 644 default-policy.json ${DESTDIR}${CONTAINERSCONFDIR}/policy.json
- install -d -m 755 ${DESTDIR}${REGISTRIESDDIR}
-- install -m 644 default.yaml ${DESTDIR}${REGISTRIESDDIR}/default.yaml
-
--install-binary: bin/skopeo
-+install-binary:
- install -d -m 755 ${DESTDIR}${BINDIR}
- install -m 755 bin/skopeo ${DESTDIR}${BINDIR}/skopeo
-
--install-docs: docs
-+install-docs:
- ifneq ($(DISABLE_DOCS), 1)
- install -d -m 755 ${DESTDIR}${MANDIR}/man1
- install -m 644 docs/*.1 ${DESTDIR}${MANDIR}/man1
- endif
-
--install-completions: completions
-+install-completions:
- install -d -m 755 ${DESTDIR}${BASHINSTALLDIR}
- install -m 644 completions/bash/skopeo ${DESTDIR}${BASHINSTALLDIR}
- install -d -m 755 ${DESTDIR}${ZSHINSTALLDIR}
- install -m 644 completions/zsh/_skopeo ${DESTDIR}${ZSHINSTALLDIR}
- install -d -m 755 ${DESTDIR}${FISHINSTALLDIR}
diff --git a/app-containers/skopeo/skopeo-1.14.0-r1.ebuild b/app-containers/skopeo/skopeo-1.14.0-r1.ebuild
deleted file mode 100644
index b7a859d817d5..000000000000
--- a/app-containers/skopeo/skopeo-1.14.0-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module linux-info
-
-DESCRIPTION="Work with remote container images registries"
-HOMEPAGE="https://github.com/containers/skopeo"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/containers/skopeo.git"
-else
- SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64"
-fi
-
-# main
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
-SLOT="0"
-IUSE="btrfs device-mapper rootless"
-
-COMMON_DEPEND="
- >=app-crypt/gpgme-1.5.5:=
- >=dev-libs/libassuan-2.4.3:=
- btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
- device-mapper? ( >=sys-fs/lvm2-2.02.145:= )
- rootless? ( sys-apps/shadow:= )
-"
-
-# TODO: Is this really needed? cause upstream doesnt mention it https://github.com/containers/skopeo/blob/main/install.md#building-from-source
-# dev-libs/libgpg-error:=
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="
- ${COMMON_DEPEND}
- app-containers/containers-common
-"
-BDEPEND="dev-go/go-md2man"
-
-RESTRICT="test"
-PATCHES=(
- "${FILESDIR}"/makefile-1.14.0.patch
-)
-
-pkg_setup() {
- use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
- use device-mapper && CONFIG_CHECK+=" ~MD"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- local file
- for file in btrfs_installed_tag btrfs_tag libdm_tag libsubid_tag; do
- [[ -f hack/"${file}".sh ]] || die
- done
-
- echo -e "#!/usr/bin/env bash\n echo" > hack/btrfs_installed_tag.sh || die
- cat <<-EOF > hack/btrfs_tag.sh || die
- #!/usr/bin/env bash
- $(usex btrfs echo 'echo exclude_graphdriver_btrfs btrfs_noversion')
- EOF
-
- cat <<-EOF > hack/libdm_tag.sh || die
- #!/usr/bin/env bash
- $(usex device-mapper echo "echo libdm_no_deferred_remove exclude_graphdriver_devicemapper")
- EOF
-
- cat <<-EOF > hack/libsubid_tag.sh || die
- #!/usr/bin/env bash
- $(usex rootless "echo libsubid" echo)
- EOF
-}
-
-src_compile() {
- # export variables which 'make install' is also going to use
- export PREFIX="${EPREFIX}/usr" \
- CONTAINERSCONFDIR="${EPREFIX}/etc/containers"
- # compile binary, docs, completions
- emake all completions
-}