summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-10 23:00:50 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-10 23:02:23 +0000
commit4f182b80d00a4bf99011ba6d8308e25e3f7d37fb (patch)
tree24bb80cd2091b5ca2c8e81173303fa4a13a4bfa0
parentapp-arch/innoextract: Assign package to proxy maintainer project. (diff)
downloadgentoo-4f182b80d00a4bf99011ba6d8308e25e3f7d37fb.tar.gz
gentoo-4f182b80d00a4bf99011ba6d8308e25e3f7d37fb.tar.bz2
gentoo-4f182b80d00a4bf99011ba6d8308e25e3f7d37fb.zip
app-arch/innoextract: Gather patches in PATCHES array.
Package-Manager: portage-2.2.26
-rw-r--r--app-arch/innoextract/innoextract-1.4.ebuild8
-rw-r--r--app-arch/innoextract/innoextract-1.5.ebuild6
2 files changed, 11 insertions, 3 deletions
diff --git a/app-arch/innoextract/innoextract-1.4.ebuild b/app-arch/innoextract/innoextract-1.4.ebuild
index 1fb858ef931c..2d889b2c743d 100644
--- a/app-arch/innoextract/innoextract-1.4.ebuild
+++ b/app-arch/innoextract/innoextract-1.4.ebuild
@@ -34,6 +34,11 @@ DEPEND="${RDEPEND}
DOCS=( README.md CHANGELOG )
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake.patch
+ "${FILESDIR}"/${P}-cmake-3.5.patch
+)
+
pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
# not sure about minimum clang req
@@ -47,8 +52,7 @@ pkg_pretend() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-cmake.patch
- epatch "${FILESDIR}"/${P}-cmake-3.5.patch
+ epatch "${PATCHES[@]}"
cmake-utils_src_prepare
}
diff --git a/app-arch/innoextract/innoextract-1.5.ebuild b/app-arch/innoextract/innoextract-1.5.ebuild
index eedb4ed6dcbb..50d0ce5b8f88 100644
--- a/app-arch/innoextract/innoextract-1.5.ebuild
+++ b/app-arch/innoextract/innoextract-1.5.ebuild
@@ -23,8 +23,12 @@ DEPEND="${RDEPEND}"
DOCS=( README.md CHANGELOG )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-cmake-3.5.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4-cmake-3.5.patch
+ epatch "${PATCHES[@]}"
cmake-utils_src_prepare
}