summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-03 09:18:06 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-03 09:58:22 +0100
commit4f1977644c438e114ec6a17eda347f820fc6e3dc (patch)
tree57afa582b3be2b8a0d00afc09c60647cc2f8d146
parentx11-terms/guake: Old. (diff)
downloadgentoo-4f197764.tar.gz
gentoo-4f197764.tar.bz2
gentoo-4f197764.zip
app-admin/ec2-ami-tools: use ruby21 with ruby-single eclass
Package-Manager: portage-2.3.0
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild (renamed from app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild)18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild
index 938f477fa980..183281837500 100644
--- a/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6.ebuild
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.5.6-r1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-inherit versionator
+USE_RUBY="ruby21"
-DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service"
+inherit ruby-single versionator
+
+DESCRIPTION="Command-line tools that serve as client interface to the Amazon EC2 web service"
HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
SRC_URI="http://s3.amazonaws.com/ec2-downloads/${P}.zip"
@@ -15,18 +17,14 @@ LICENSE="Amazon
SLOT="0"
KEYWORDS="~amd64 ~x86"
-ruby_slot="2.0"
-
DEPEND="app-arch/unzip"
-RDEPEND="dev-lang/ruby:${ruby_slot}[ssl]
+RDEPEND="
+ ${RUBY_DEPS}
+ virtual/ruby-ssl
net-misc/rsync
net-misc/curl"
src_prepare() {
- # Simplify the scripts to always run Ruby 20, since Gentoo supports
- # alternative implementations as well it is not guaranteed that ruby is ruby19.
- sed -i -e "\$s:^ruby:exec ruby${ruby_slot/./}:" bin/* || die 'Sed failed.'
-
# Remove a left behind license file.
rm lib/ec2/oem/LICENSE.txt || die 'Removal of LICENSE failed.'
}