summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 09:54:05 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 10:31:52 +0200
commit4f362598cbc158e26b9db8aebe841d8aff408b23 (patch)
treecc4d7e1e8efd01683b8e2e5450b369e45f237f13
parentdev-python/vo: Correct blocker against astropy and fix distutils-r1.eclass usage (diff)
downloadgentoo-4f362598.tar.gz
gentoo-4f362598.tar.bz2
gentoo-4f362598.zip
dev-python/pywcs: Correct blocker against astropy and fix distutils-r1.eclass usage
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/pywcs/metadata.xml4
-rw-r--r--dev-python/pywcs/pywcs-1.11-r1.ebuild9
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/pywcs/metadata.xml b/dev-python/pywcs/metadata.xml
index 380f3bfe46bb..69c03782c80f 100644
--- a/dev-python/pywcs/metadata.xml
+++ b/dev-python/pywcs/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-astronomy</herd>
-<longdescription lang="en">
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
pywcs is a set of routines for handling the FITS World Coordinate
System (WCS) standard. It is a thin wrapper around the high- and
mid-level interfaces for wcslib.
diff --git a/dev-python/pywcs/pywcs-1.11-r1.ebuild b/dev-python/pywcs/pywcs-1.11-r1.ebuild
index ee7041a6c912..e9509bbb759f 100644
--- a/dev-python/pywcs/pywcs-1.11-r1.ebuild
+++ b/dev-python/pywcs/pywcs-1.11-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit distutils-r1 eutils
+inherit distutils-r1
WCS_V=4.8.2
MYP=${P}-${WCS_V}
@@ -26,15 +26,14 @@ DEPEND="
RDEPEND="
>=sci-astronomy/wcslib-${WCS_V}
virtual/pyfits
- !<dev-python/astropy-0.3"
+ !dev-python/astropy"
# missing data to run tests
RESTRICT=test
+
S="${WORKDIR}/${MYP}"
-python_prepare_all(){
- epatch "${FILESDIR}"/${P}-wcslib.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-wcslib.patch )
python_test() {
nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"