summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-03 00:23:18 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-03 00:23:30 +0100
commit4f43ddf429a1b442a48890b348583330ad99936b (patch)
treecfd3266f9dc7b5f2546698297e539141ff431ad4
parentx11-plugins/wmping: fix build with -fno-common (diff)
downloadgentoo-4f43ddf4.tar.gz
gentoo-4f43ddf4.tar.bz2
gentoo-4f43ddf4.zip
x11-plugins/fsviewer: fix build with -fno-common
Closes: https://bugs.gentoo.org/706972 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch26
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild3
2 files changed, 28 insertions, 1 deletions
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch
new file mode 100644
index 000000000000..00c5e651e69c
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc-10.patch
@@ -0,0 +1,26 @@
+diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.c fsviewer-app-0.2.6/src/FSViewer.c
+--- fsviewer-app-0.2.6.orig/src/FSViewer.c 2007-10-14 17:29:04.000000000 +0200
++++ fsviewer-app-0.2.6/src/FSViewer.c 2020-02-03 00:20:37.979716353 +0100
+@@ -25,6 +25,8 @@
+ static Bool focusIn;
+ int ModifierFromKey(Display *dpy, char *key);
+
++WMUserDefaults *defaultsDB;
++WMPropList *filesDB;
+ void
+ wAbort(Bool foo)
+ {
+diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.h fsviewer-app-0.2.6/src/FSViewer.h
+--- fsviewer-app-0.2.6.orig/src/FSViewer.h 2006-07-23 09:24:15.000000000 +0200
++++ fsviewer-app-0.2.6/src/FSViewer.h 2020-02-03 00:20:39.299718025 +0100
+@@ -123,8 +123,8 @@
+ } CallbackRec;
+
+ /* Application defaults */
+-WMUserDefaults *defaultsDB;
+-WMPropList *filesDB;
++extern WMUserDefaults *defaultsDB;
++extern WMPropList *filesDB;
+
+ /* all Panels must start with the following layout */
+ typedef struct PanelRec {
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild
index 83bc210ced4d..9e5972eaf1e1 100644
--- a/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild
+++ b/x11-plugins/fsviewer/fsviewer-0.2.6-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,6 +30,7 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc5.patch
"${FILESDIR}"/${P}-wmaker-0.95_support.patch
"${FILESDIR}"/${P}-fix_title_bar.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
)
DOCS="AUTHORS ChangeLog NEWS README"