summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 04:34:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:37:21 +0200
commit4f67c375500b21173fc8618f1c3838acfe58fb77 (patch)
tree486265c81205fe015508cd8e057e7cc3c47f18c0
parentdev-python/mkdocstrings: Bump to 0.25.0 (diff)
downloadgentoo-4f67c375500b21173fc8618f1c3838acfe58fb77.tar.gz
gentoo-4f67c375500b21173fc8618f1c3838acfe58fb77.tar.bz2
gentoo-4f67c375500b21173fc8618f1c3838acfe58fb77.zip
dev-python/cairocffi: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cairocffi/Manifest1
-rw-r--r--dev-python/cairocffi/cairocffi-1.7.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cairocffi/Manifest b/dev-python/cairocffi/Manifest
index 2a442a821865..1dc1807d7404 100644
--- a/dev-python/cairocffi/Manifest
+++ b/dev-python/cairocffi/Manifest
@@ -1 +1,2 @@
DIST cairocffi-1.6.1.tar.gz 87436 BLAKE2B 54f7f3db31ab52aac6ebce1c830c4c0ff2f5ffde1f6a803bf8453b0ab3307414732c2e43b5b931ff77c9cbf6fe3229150e49254f13891f5e75e88eeef73970b9 SHA512 5489263b7e7e2aca7291860a90a6339d35e819cc03a9add47cd21b4ec0cb0274445c3e852ee3be127c42d8b5d9fcb98b02ff7eb66e3d9d243bd33527ce6ddf5c
+DIST cairocffi-1.7.0.tar.gz 87840 BLAKE2B f31a07c865e16fb5448451bb2a57c2f33017165d2c374a4ea60222a28dc7a9bfd9839a6014594c5e90cc8880773e85cbb29e5bcc5c32d0150b07274f25f81b94 SHA512 bfc0f388a6ea1885523d99ad0ccfd59fec89848ef053c240ea9e3e8aab3f3aed5dc343b74de5cc72fb8512d460e55c70ef99a4ae4705fb1dd92d654a4197d7a9
diff --git a/dev-python/cairocffi/cairocffi-1.7.0.ebuild b/dev-python/cairocffi/cairocffi-1.7.0.ebuild
new file mode 100644
index 000000000000..0b901aa4578f
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-1.7.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+HOMEPAGE="
+ https://github.com/Kozea/cairocffi/
+ https://pypi.org/project/cairocffi/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ x11-libs/cairo:0=[X,xcb(+)]
+ x11-libs/gdk-pixbuf[jpeg]
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pikepdf[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-tests.patch
+)
+
+src_test() {
+ virtx distutils-r1_src_test
+}