summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-02-01 17:45:56 +0800
committerSam James <sam@gentoo.org>2023-02-08 04:17:29 +0000
commit4f749acaea36d8ef66c2c4834c598247bb15ae41 (patch)
tree44d910248bd5412f2eb4ef136ecd54e69555f5a1
parentdev-libs/rocm-opencl-runtime: simplify ebuild (diff)
downloadgentoo-4f749aca.tar.gz
gentoo-4f749aca.tar.bz2
gentoo-4f749aca.zip
dev-util/roctracer: strip -Werror and fix a configure issue
hip-config.cmake run ${HIP_CXX_COMPILER} -print-resource-dir to determine some paths. By default, HIP_CXX_COMPILER=${CMAKE_CXX_COMPILER}=gcc, causing configuration issues, so set HIP_CXX_COMPILER=hipcc. Closes: https://bugs.gentoo.org/891945 Bug: https://bugs.gentoo.org/892730 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29376 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/roctracer/files/roctracer-5.3.3-Werror.patch15
-rw-r--r--dev-util/roctracer/roctracer-5.3.3.ebuild4
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-util/roctracer/files/roctracer-5.3.3-Werror.patch b/dev-util/roctracer/files/roctracer-5.3.3-Werror.patch
new file mode 100644
index 000000000000..b932bb5cb5d3
--- /dev/null
+++ b/dev-util/roctracer/files/roctracer-5.3.3-Werror.patch
@@ -0,0 +1,15 @@
+Should not use the aggressive -Werror flag.
+
+Index: roctracer-rocm-5.3.3/CMakeLists.txt
+===================================================================
+--- roctracer-rocm-5.3.3.orig/CMakeLists.txt
++++ roctracer-rocm-5.3.3/CMakeLists.txt
+@@ -37,7 +37,7 @@ endif()
+
+ set(CMAKE_CXX_STANDARD 17)
+ set(CMAKE_CXX_STANDARD_REQUIRED ON)
+-add_compile_options(-Wall -Werror)
++add_compile_options(-Wall)
+
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+
diff --git a/dev-util/roctracer/roctracer-5.3.3.ebuild b/dev-util/roctracer/roctracer-5.3.3.ebuild
index a053427379df..23e3d7e714e7 100644
--- a/dev-util/roctracer/roctracer-5.3.3.ebuild
+++ b/dev-util/roctracer/roctracer-5.3.3.ebuild
@@ -31,7 +31,8 @@ BDEPEND="
"
PATCHES=( "${FILESDIR}"/roctracer-5.3.3-flat-lib-layout.patch
- "${FILESDIR}"/roctracer-5.3.3-do-not-install-test-files.patch )
+ "${FILESDIR}"/roctracer-5.3.3-do-not-install-test-files.patch
+ "${FILESDIR}"/roctracer-5.3.3-Werror.patch )
python_check_deps() {
python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
@@ -51,6 +52,7 @@ src_configure() {
-DCMAKE_MODULE_PATH="${EPREFIX}/usr/lib64/cmake/hip"
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
-DFILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DHIP_CXX_COMPILER=hipcc
)
cmake_src_configure