summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-06-03 23:19:31 +0200
committerSam James <sam@gentoo.org>2022-06-04 04:27:32 +0100
commit4f754696082002eb5a4debed1b0b61e4404246cb (patch)
treec25ba9c70e50f94179796cb4ed733ccd916e3a32
parentdev-python/python-dbusmock: skip hanging test which was dropped upstream (diff)
downloadgentoo-4f754696.tar.gz
gentoo-4f754696.tar.bz2
gentoo-4f754696.zip
sci-geosciences/grass: version bump 8.2.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/25744 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/grass/Manifest1
-rw-r--r--sci-geosciences/grass/grass-8.2.0.ebuild283
2 files changed, 284 insertions, 0 deletions
diff --git a/sci-geosciences/grass/Manifest b/sci-geosciences/grass/Manifest
index cd51431391bf..4fa939f09a8e 100644
--- a/sci-geosciences/grass/Manifest
+++ b/sci-geosciences/grass/Manifest
@@ -2,3 +2,4 @@ DIST grass-7.8.6.tar.gz 66331264 BLAKE2B bb5a3387f74bc30b7ce3230765cecdc7e61ded8
DIST grass-7.8.7.tar.gz 66333084 BLAKE2B 809daed6992838cd89b7f913c92bb588db05ae933c6e05b6fbd1add135dc36238260222f338df023c402b411b6c0338a56e06268d1fb736e9d9f6779bc2e4c42 SHA512 8c890b34a64c3a52285a8d99e2a2ec61b41de0258ae5b70d1876499988a9a8229925b82f4595df6b5cf21b77ecc8529feb75f765d4e92f324a734293dffc7303
DIST grass-8.0.1.tar.gz 64928098 BLAKE2B 81512a5e95727202705a06e11dcb243a393bb6d7b5756957ffe055c867aa18933d84a31ed5e006e8c25bff558aa3ce5acab9e90660b1537192ffa11c92cdf4cc SHA512 ec0e52bfe22179c85bb7119980ab4d5b96278fc85d1fc5c0781aea1864e89a302677fa008b65f0398d564fd6ffc05cee0da1b81affb489c89c20a3bd9f6b089f
DIST grass-8.0.2.tar.gz 65665825 BLAKE2B 496dab376b38c74d2206096f8b1bf848888c328be3871fca5173042d7368f5c40cdbb6908ed69ec9f2c0669b25f3cfc50b4105f9bb7b375c379b9cc518ebfe8f SHA512 fc6f45f2b6ac2507c70a14baa931d5c66f0b115c914081d24c95f40afa6c266a718026df895f7a182ea837c6abf70da15b09dccba39eedd6a71ba7b6301edf7c
+DIST grass-8.2.0.tar.gz 66819726 BLAKE2B e4398368dd8fd26324709202f42556033a0fea12b6bf5b300c9c416e8758472ceacf40e1d3d540b1aefea88199c0f411462a64fc5e09864582e2e4ce743d67f3 SHA512 8179b8704ea688ba412496d0e149c5a47b89fd557b613a49f3addb9721f166cd3aa23ff2549832d9940e5065893e3257ce7287e75018a3468aa7847392398930
diff --git a/sci-geosciences/grass/grass-8.2.0.ebuild b/sci-geosciences/grass/grass-8.2.0.ebuild
new file mode 100644
index 000000000000..d326298a52b2
--- /dev/null
+++ b/sci-geosciences/grass/grass-8.2.0.ebuild
@@ -0,0 +1,283 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite" # bug 572440
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools desktop python-single-r1 toolchain-funcs wxwidgets xdg
+
+DESCRIPTION="A free GIS with raster and vector functionality, as well as 3D vizualization"
+HOMEPAGE="https://grass.osgeo.org/"
+
+LICENSE="GPL-2"
+SLOT="0/8.2"
+
+GVERSION=${SLOT#*/}
+MY_PM="${PN}${GVERSION}"
+MY_PM="${MY_PM/.}"
+
+if [[ ${PV} =~ "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/OSGeo/grass.git"
+else
+ MY_P="${P/_rc/RC}"
+ SRC_URI="https://grass.osgeo.org/${MY_PM}/source/${MY_P}.tar.gz"
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~ppc ~x86"
+ fi
+
+ S="${WORKDIR}/${MY_P}"
+fi
+
+IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp png postgres readline sqlite threads tiff truetype X zstd"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ opengl? ( X )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-admin/eselect-1.2
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ sci-libs/gdal:=
+ sys-libs/gdbm:=
+ sys-libs/ncurses:0=
+ sci-libs/proj:=
+ sci-libs/xdrfile
+ sys-libs/zlib
+ media-libs/libglvnd
+ media-libs/glu
+ blas? (
+ virtual/cblas[eselect-ldso(+)]
+ virtual/blas[eselect-ldso(+)]
+ )
+ fftw? ( sci-libs/fftw:3.0= )
+ geos? ( sci-libs/geos:= )
+ lapack? ( virtual/lapack[eselect-ldso(+)] )
+ las? ( sci-geosciences/liblas )
+ mysql? ( dev-db/mysql-connector-c:= )
+ netcdf? ( sci-libs/netcdf:= )
+ odbc? ( dev-db/unixODBC )
+ opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
+ png? ( media-libs/libpng:0= )
+ postgres? ( >=dev-db/postgresql-8.4:= )
+ readline? ( sys-libs/readline:0= )
+ sqlite? ( dev-db/sqlite:3 )
+ tiff? ( media-libs/tiff:0= )
+ truetype? ( media-libs/freetype:2 )
+ X? (
+ dev-python/wxpython:4.0
+ x11-libs/cairo[X,opengl?]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ )
+ zstd? ( app-arch/zstd )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? ( dev-lang/swig )"
+
+PATCHES=(
+ # bug 746590
+ "${FILESDIR}/${PN}-flock.patch"
+)
+
+pkg_setup() {
+ if use lapack; then
+ local mylapack=$(eselect lapack show)
+ if [[ -z "${mylapack/.*reference.*/}" ]] && \
+ [[ -z "${mylapack/.*atlas.*/}" ]]; then
+ ewarn "You need to set lapack to atlas or reference. Do:"
+ ewarn " eselect lapack set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ if use blas; then
+ local myblas=$(eselect blas show)
+ if [[ -z "${myblas/.*reference.*/}" ]] && \
+ [[ -z "${myblas/.*atlas.*/}" ]]; then
+ ewarn "You need to set blas to atlas or reference. Do:"
+ ewarn " eselect blas set <impl>"
+ ewarn "where <impl> is atlas, threaded-atlas or reference"
+ die "setup failed"
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix unversioned python calls
+ sed -e "s:=python3:=${EPYTHON}:" -i "${S}/lib/init/grass.sh" || die
+ sed -e "s:= python3:= ${EPYTHON}:" -i "${S}/include/Make/Platform.make.in" || die
+
+ default
+ eautoreconf
+
+ ebegin "Fixing python shebangs"
+ python_fix_shebang -q "${S}"
+ eend $?
+
+ # For testsuite, see https://bugs.gentoo.org/show_bug.cgi?id=500580#c3
+ shopt -s nullglob
+ local mesa_cards=$(echo -n /dev/dri/card* /dev/dri/render* | sed 's/ /:/g')
+ if test -n "${mesa_cards}"; then
+ addpredict "${mesa_cards}"
+ fi
+ local ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if test -n "${ati_cards}"; then
+ addpredict "${ati_cards}"
+ fi
+ shopt -u nullglob
+ addpredict /dev/nvidiactl
+}
+
+src_configure() {
+ if use X; then
+ local WX_BUILD=yes
+ setup-wxwidgets
+ fi
+
+ addwrite /dev/dri/renderD128
+
+ local myeconfargs=(
+ --enable-shared
+ --disable-w11
+ --without-opendwg
+ --with-regex
+ --with-gdal="${EPREFIX}"/usr/bin/gdal-config
+ --with-proj-includes="${EPREFIX}"/usr/include/proj
+ --with-proj-libs="${EPREFIX}"/usr/$(get_libdir)
+ --with-proj-share="${EPREFIX}"/usr/share/proj/
+ $(use_with cxx)
+ $(use_with tiff)
+ $(use_with png)
+ $(use_with postgres)
+ $(use_with mysql)
+ $(use_with mysql mysql-includes "${EPREFIX}"/usr/include/mysql)
+ $(use_with sqlite)
+ $(use_with opengl)
+ $(use_with odbc)
+ $(use_with fftw)
+ $(use_with blas)
+ $(use_with lapack)
+ $(use_with X cairo)
+ $(use_with truetype freetype)
+ $(use_with truetype freetype-includes "${EPREFIX}"/usr/include/freetype2)
+ $(use_with nls)
+ $(use_with readline)
+ $(use_with threads pthread)
+ $(use_with openmp)
+ $(use_with opencl)
+ $(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
+ $(use_with X wxwidgets "${WX_CONFIG}")
+ $(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)
+ $(use_with geos geos "${EPREFIX}"/usr/bin/geos-config)
+ $(use_with X x)
+ $(use_with zstd)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # we don't want to link against embedded mysql lib
+ emake CC="$(tc-getCC)" MYSQLDLIB=""
+}
+
+src_install() {
+ emake DESTDIR="${ED}" \
+ INST_DIR=/usr/$(get_libdir)/${MY_PM} \
+ prefix=/usr/ BINDIR=/usr/bin \
+ install
+
+ pushd "${ED}"/usr/$(get_libdir)/${MY_PM} >/dev/null || die
+
+ local HTML_DOCS=( docs/html/. )
+ einstalldocs
+
+ # translations
+ if use nls; then
+ insinto /usr/share/locale
+ doins -r locale/.
+ fi
+
+ popd >/dev/null || die
+
+ # link libraries in the ~standard~ place
+ local f file
+ for f in "${ED}"/usr/$(get_libdir)/${MY_PM}/lib/*; do
+ file="${f##*/}"
+ dosym ${MY_PM}/lib/${file} /usr/$(get_libdir)/${file}
+ done
+
+ # link headers in the ~standard~ place
+ dodir /usr/include/
+ dosym ../$(get_libdir)/${MY_PM}/include/grass /usr/include/grass
+
+ # fix paths in addons makefile includes
+ local scriptMakeDir="${ED}"/usr/$(get_libdir)/${MY_PM}/include/Make/
+ for f in "${scriptMakeDir}"/*; do
+ file="${f##*/}"
+ echo sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
+ sed -i "s|${ED}|/|g" "${scriptMakeDir}/${file}" || die
+ done
+
+ # get proper folder for grass path in script
+ local gisbase=/usr/$(get_libdir)/${MY_PM}
+ sed -e "s:GISBASE = os.path.normpath(\"${D}/usr/$(get_libdir)/${MY_PM}\"):\
+GISBASE = os.path.normpath(\"${gisbase}\"):" \
+ -i "${ED}"/usr/bin/grass || die
+
+ # get proper fonts path for fontcap
+ sed -i \
+ -e "s|${ED}/usr/${MY_PM}|${EPREFIX}/usr/$(get_libdir)/${MY_PM}|" \
+ "${ED}"${gisbase}/etc/fontcap || die
+
+ # set proper python interpreter
+ sed -e "s:os.environ\[\"GRASS_PYTHON\"\] = \"python3\":\
+os.environ\[\"GRASS_PYTHON\"\] = \"${EPYTHON}\":" \
+ -i "${ED}"/usr/bin/grass || die
+
+ # set proper GISDBASE directory path in the demolocation .grassrc${GVERSION//.} file
+ sed -e "s:GISDBASE\:.*$:GISDBASE\: ${gisbase}:" \
+ -i "${ED}"${gisbase}/demolocation/.grassrc${GVERSION//.} || die
+
+ if use X; then
+ local GUI="-gui"
+ [[ ${WX_BUILD} == yes ]] && GUI="-wxpython"
+ make_desktop_entry "/usr/bin/grass ${GUI}" "${PN}" "${PN}-48x48" "Science;Education"
+ doicon -s 48 gui/icons/${PN}-48x48.png
+ fi
+
+ # install .pc file so other apps know where to look for grass
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins grass.pc
+
+ # fix weird +x on tcl scripts
+ find "${ED}" -name "*.tcl" -exec chmod +r-x '{}' \; || die
+}
+
+pkg_postinst() {
+ use X && xdg_pkg_postinst
+ ewarn 'Starting with version 8.0.2 the "liblas" USE flag has been renamed'
+ ewarn 'to "las" in order to match dev-games/openscenegraph (Bug 680854)'
+}
+
+pkg_postrm() {
+ use X && xdg_pkg_postrm
+}