summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-20 13:58:32 +0100
committerSam James <sam@gentoo.org>2023-05-20 13:59:57 +0100
commit4f8098bdc3db1817dcdf3956ec6dba61703f2ed4 (patch)
treea71660e0b3b59f22c55aff904899925b18286069
parentdev-python/sabyenc: destabilize 7.0.2 for ~amd64 (diff)
downloadgentoo-4f8098bdc3db1817dcdf3956ec6dba61703f2ed4.tar.gz
gentoo-4f8098bdc3db1817dcdf3956ec6dba61703f2ed4.tar.bz2
gentoo-4f8098bdc3db1817dcdf3956ec6dba61703f2ed4.zip
app-doc/doxygen: fix spdlog usage
It's linked statically normally but if we force dynamic linking, it ends up using but then not installing (bundled, just-built) libspdlog. Bug: https://bugs.gentoo.org/906848 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-doc/doxygen/doxygen-1.9.7-r1.ebuild (renamed from app-doc/doxygen/doxygen-1.9.7.ebuild)4
-rw-r--r--app-doc/doxygen/doxygen-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-doc/doxygen/doxygen-1.9.7.ebuild b/app-doc/doxygen/doxygen-1.9.7-r1.ebuild
index b59798ef9a23..74b00ea0082d 100644
--- a/app-doc/doxygen/doxygen-1.9.7.ebuild
+++ b/app-doc/doxygen/doxygen-1.9.7-r1.ebuild
@@ -19,7 +19,8 @@ fi
DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="https://www.doxygen.nl/"
-LICENSE="GPL-2"
+# GPL-2 also for bundled libmscgen, MIT for bundled spdlog
+LICENSE="GPL-2 MIT"
SLOT="0"
IUSE="clang debug doc dot doxysearch qt5 sqlite test"
# We need TeX for tests, bug #765472
@@ -105,6 +106,7 @@ src_configure() {
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
+ -DBUILD_SHARED_LIBS=OFF
-DGIT_EXECUTABLE="false"
)
diff --git a/app-doc/doxygen/doxygen-9999.ebuild b/app-doc/doxygen/doxygen-9999.ebuild
index b59798ef9a23..74b00ea0082d 100644
--- a/app-doc/doxygen/doxygen-9999.ebuild
+++ b/app-doc/doxygen/doxygen-9999.ebuild
@@ -19,7 +19,8 @@ fi
DESCRIPTION="Documentation system for most programming languages"
HOMEPAGE="https://www.doxygen.nl/"
-LICENSE="GPL-2"
+# GPL-2 also for bundled libmscgen, MIT for bundled spdlog
+LICENSE="GPL-2 MIT"
SLOT="0"
IUSE="clang debug doc dot doxysearch qt5 sqlite test"
# We need TeX for tests, bug #765472
@@ -105,6 +106,7 @@ src_configure() {
-Dbuild_search=$(usex doxysearch)
-Dbuild_wizard=$(usex qt5)
-Duse_sqlite3=$(usex sqlite)
+ -DBUILD_SHARED_LIBS=OFF
-DGIT_EXECUTABLE="false"
)