summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-03 10:13:54 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-03 10:13:54 -0500
commit4fbb75c002aebdf23915c9f9580b9271c39442c2 (patch)
treed29d8928314fcaf31858f0c27be8327f70ad3b9c
parentgames-fps/sauerbraten: remove unneeded nonfatal (bug #551172) (diff)
downloadgentoo-4fbb75c0.tar.gz
gentoo-4fbb75c0.tar.bz2
gentoo-4fbb75c0.zip
net-libs/enet: inherit eutils instead of base
Package-Manager: portage-2.2.24
-rw-r--r--net-libs/enet/enet-1.3.13.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/net-libs/enet/enet-1.3.13.ebuild b/net-libs/enet/enet-1.3.13.ebuild
index ff7aaaa1a2d7..83588c5fb1ed 100644
--- a/net-libs/enet/enet-1.3.13.ebuild
+++ b/net-libs/enet/enet-1.3.13.ebuild
@@ -3,8 +3,7 @@
# $Id$
EAPI=5
-
-inherit base
+inherit eutils
DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/"
@@ -17,17 +16,11 @@ IUSE="static-libs"
RDEPEND="!${CATEGORY}/${PN}:0"
-DOCS=( "ChangeLog" "README" )
-
src_configure() {
- econf \
- --disable-dependency-tracking \
- $(use_enable static-libs static)
+ econf $(use_enable static-libs static)
}
src_install() {
- base_src_install
- if ! use static-libs ; then
- find "${D}" -type f -name '*.la' -exec rm {} + || die
- fi
+ default
+ prune_libtool_files
}