summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-01 08:14:37 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-01 08:15:30 +0100
commit4fcdd7977ac52cb2bdc9c5ebaa71ee1dd409612e (patch)
treec420d9f2a8f02c7edf3a0d2868ba3577746c7753
parentnet-fs/samba: Removed old (diff)
downloadgentoo-4fcdd797.tar.gz
gentoo-4fcdd797.tar.bz2
gentoo-4fcdd797.zip
dev-libs/libxmlb: Bump to version 0.3.4
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/libxmlb/Manifest1
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index 708967cbffca..51db30665109 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,3 +1,4 @@
DIST libxmlb-0.1.15.tar.gz 92923 BLAKE2B 97b6af812397dd279e7e3c038627fcf8228cbfa5c3af91ceeb5361e32d37d357eda6a193f627a5f4442426fb08abca1ff11684fe199d9d3a4add72ca4f3f5d08 SHA512 58268b3a690af36c0923afdee3ae58e88bf778eebbc6a439be1bc85ed985efdc20cd7006c976586f7be87310dc091d67dddd370f4bbec58379fc4e7349bfa3d8
DIST libxmlb-0.3.2.tar.gz 113428 BLAKE2B 30f29ebd7522ee2338b4e78e15a544bdf20514e151e63d555be29fca63a3c8251c8d340f778ba1b6b6484c084ab145f9e9d1d4acf037b3f1abad05c5b0101082 SHA512 d4c1cbb8dfd2da9f4b9f436fbba5102f0391df7786a1c0bb1543841eaa5928ac72e6d8125e263be51c69627574bfea70d72624385086879cdbdb44721c0daa3d
DIST libxmlb-0.3.3.tar.gz 116107 BLAKE2B 604228a997618b0a3fc25a652f30c1761bc95649246310354c8ca76b6b189799ba8fa38a21244e354d42d6c0f1fd1640e71ccc7ff48429d3425ae43787cf4648 SHA512 4d06e7a7d4bf2e7d36713134b95a6d78e79f014e4b0b511ec9b11086e7287f9f5a42496c4bce35ecae68de1333d7e14b9d041b71c9a081267452178dd2405e16
+DIST libxmlb-0.3.4.tar.gz 118304 BLAKE2B e66d6ca72b2e2b568a2775ee44f4eba0c620b50515bb809ab585f488811e5760a61a79a77535c4f3e5ade029687443b4c780abb5eaa29cc044610e2bfe33eb87 SHA512 91ea55fc35e71a6e8c4ec2a07d19d6da27d3a40ac3958285bb15ad6b05a12d944d15f1987d5e8557c8ec1c28b753c1b267670a8e73790e0003ef4d990d617e75
diff --git a/dev-libs/libxmlb/libxmlb-0.3.4.ebuild b/dev-libs/libxmlb/libxmlb-0.3.4.ebuild
new file mode 100644
index 000000000000..84e2880a46ac
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc introspection stemmer test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/xz-utils
+ dev-libs/glib:2
+ sys-apps/util-linux
+ stemmer? ( dev-libs/snowball-stemmer:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-util/meson-0.47.0
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+
+python_check_deps() {
+ has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc gtkdoc)
+ $(meson_use introspection)
+ $(meson_use stemmer)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}