summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 11:36:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 11:36:02 +0200
commit4ff4eeca25482d8827c179579262bd5e51551e5b (patch)
treec89114659838e673bd422cfa687130c73fb5f025
parentdev-ros/genlisp: bump to 0.4.16 (diff)
downloadgentoo-4ff4eeca.tar.gz
gentoo-4ff4eeca.tar.bz2
gentoo-4ff4eeca.zip
dev-python/vcstools: bump to 0.1.39
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/vcstools/Manifest1
-rw-r--r--dev-python/vcstools/vcstools-0.1.39.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/vcstools/Manifest b/dev-python/vcstools/Manifest
index bad9fdca4b21..1893f4bfa170 100644
--- a/dev-python/vcstools/Manifest
+++ b/dev-python/vcstools/Manifest
@@ -1 +1,2 @@
DIST vcstools-0.1.38.tar.gz 54671 SHA256 0e3d2b5681c2776453fb5b61ceab61fdb965d5342e46c08a5b62095eb0237117 SHA512 a3693d34777235e562a5db006af8f33590df99ffce96f5d3cfd2d816ebdc23ee5fb3536bf289b64a36588e60ce20ce8396a448394f300a12672fd8bf5800973e WHIRLPOOL 86fccbb181849f2b60d8159073bb3de659b7d96173952cb9b68a2869048827c48860fb67859db1341a0defeee0915d41c1d6e77e812f807ca11e91e92e0ed250
+DIST vcstools-0.1.39.tar.gz 51610 SHA256 841bdfeca326b532ced45feea2a79b48008415ef117df008071ba74e985f59c1 SHA512 163ced29baa158d915169a4f8f432bd9ad60ddcd5abae0d3801b5d970049d717c11bd8aa95f7af9dfe48cdcbcce49d14331a82a9c41b9ded1ce4caa2e27cd901 WHIRLPOOL 1c47eda1e0e383336d8d940c4bf063c3aac04e21870d0fa567e239a882216ad857cf184afcef409a0645c38da069a9d1b5c34f1638230c1d59c6d8b7166b618e
diff --git a/dev-python/vcstools/vcstools-0.1.39.ebuild b/dev-python/vcstools/vcstools-0.1.39.ebuild
new file mode 100644
index 000000000000..22eb44c3cd5c
--- /dev/null
+++ b/dev-python/vcstools/vcstools-0.1.39.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/vcstools"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Python library for interacting with various VCS systems"
+HOMEPAGE="http://wiki.ros.org/vcstools"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ dev-vcs/subversion
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ #git config --global user.email "you@example.com"
+ #git config --global user.name "Your Name"
+
+ nosetests --with-coverage --cover-package vcstools || die
+}