summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-05 11:52:36 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-05 12:14:21 +0200
commit4ffb3c05ffea51b9145adfea5ed8290663565e3c (patch)
treeea2460263712e3c1b95133d125ef565b658f8669
parentdev-embedded/sdcc: Bump to 4.2.0 (diff)
downloadgentoo-4ffb3c05ffea51b9145adfea5ed8290663565e3c.tar.gz
gentoo-4ffb3c05ffea51b9145adfea5ed8290663565e3c.tar.bz2
gentoo-4ffb3c05ffea51b9145adfea5ed8290663565e3c.zip
dev-embedded/sdcc: enable and remove USE sdbinutils
REQUIRED_USE requires at least one port. Any port requires the `sdbinutils` USE flag. Remove the flag and have it always enabled. I tried to compile without it, the build fails, so it was useless anyway. Fix SRC_URI permanent redirect and https HOMEPAGE. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-embedded/sdcc/sdcc-4.2.0.ebuild25
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild25
2 files changed, 16 insertions, 34 deletions
diff --git a/dev-embedded/sdcc/sdcc-4.2.0.ebuild b/dev-embedded/sdcc/sdcc-4.2.0.ebuild
index 672ec63f733d..dc4655403f3d 100644
--- a/dev-embedded/sdcc/sdcc-4.2.0.ebuild
+++ b/dev-embedded/sdcc/sdcc-4.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,15 +10,15 @@ if [[ ${PV} == "9999" ]] ; then
inherit subversion
else
SRC_URI="
- mirror://sourceforge/sdcc/${PN}-src-${PV}.tar.bz2
- doc? ( mirror://sourceforge/sdcc/${PN}-doc-${PV}.tar.bz2 )
+ https://downloads.sourceforge.net/project/${PN}/sdcc/${PV}/${PN}-src-${PV}.tar.bz2
+ doc? ( https://downloads.sourceforge.net/project/${PN}/sdcc-doc/${PV}/${PN}-doc-${PV}.tar.bz2 )
"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Small device C compiler (for various microprocessors)"
-HOMEPAGE="http://sdcc.sourceforge.net/"
+HOMEPAGE="https://sdcc.sourceforge.net/"
LICENSE="
GPL-2 ZLIB
@@ -45,24 +45,15 @@ SDCC_PORTS="
"
IUSE="
${SDCC_PORTS}
- +boehm-gc device-lib doc non-free packihx +sdbinutils sdcdb +sdcpp ucsim
-"
-
-for port in ${SDCC_PORTS}; do
-REQUIRED_USE="${REQUIRED_USE}
- ${port}? ( sdbinutils )
-"
-done
-REQUIRED_USE="${REQUIRED_USE}
- || ( ${SDCC_PORTS} )
+ +boehm-gc device-lib doc non-free packihx sdcdb +sdcpp ucsim
"
RDEPEND="
dev-libs/boost:=
+ sys-libs/zlib:=
pic14? ( >=dev-embedded/gputils-0.13.7 )
pic16? ( >=dev-embedded/gputils-0.13.7 )
boehm-gc? ( dev-libs/boehm-gc:= )
- sdbinutils? ( sys-libs/zlib:= )
sdcdb? ( sys-libs/readline:0= )
ucsim? ( sys-libs/ncurses:= )
"
@@ -106,13 +97,13 @@ src_configure() {
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache
+ --enable-sdbinutils
$(use_enable ucsim)
$(use_enable device-lib)
$(use_enable packihx)
$(use_enable sdcpp)
$(use_enable sdcdb)
- $(use_enable sdbinutils)
$(use_enable non-free)
$(use_enable boehm-gc libgc)
@@ -158,7 +149,7 @@ src_compile() {
src_install() {
default
dodoc doc/*.txt
- find "${D}" -type d -name .deps -exec rm -vrf {} + || die
+ find "${ED}" -type d -name .deps -exec rm -vr {} + || die
if use doc && [[ ${PV} != "9999" ]]; then
cd "${WORKDIR}"/doc
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index 672ec63f733d..dc4655403f3d 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,15 +10,15 @@ if [[ ${PV} == "9999" ]] ; then
inherit subversion
else
SRC_URI="
- mirror://sourceforge/sdcc/${PN}-src-${PV}.tar.bz2
- doc? ( mirror://sourceforge/sdcc/${PN}-doc-${PV}.tar.bz2 )
+ https://downloads.sourceforge.net/project/${PN}/sdcc/${PV}/${PN}-src-${PV}.tar.bz2
+ doc? ( https://downloads.sourceforge.net/project/${PN}/sdcc-doc/${PV}/${PN}-doc-${PV}.tar.bz2 )
"
KEYWORDS="~amd64 ~x86"
fi
DESCRIPTION="Small device C compiler (for various microprocessors)"
-HOMEPAGE="http://sdcc.sourceforge.net/"
+HOMEPAGE="https://sdcc.sourceforge.net/"
LICENSE="
GPL-2 ZLIB
@@ -45,24 +45,15 @@ SDCC_PORTS="
"
IUSE="
${SDCC_PORTS}
- +boehm-gc device-lib doc non-free packihx +sdbinutils sdcdb +sdcpp ucsim
-"
-
-for port in ${SDCC_PORTS}; do
-REQUIRED_USE="${REQUIRED_USE}
- ${port}? ( sdbinutils )
-"
-done
-REQUIRED_USE="${REQUIRED_USE}
- || ( ${SDCC_PORTS} )
+ +boehm-gc device-lib doc non-free packihx sdcdb +sdcpp ucsim
"
RDEPEND="
dev-libs/boost:=
+ sys-libs/zlib:=
pic14? ( >=dev-embedded/gputils-0.13.7 )
pic16? ( >=dev-embedded/gputils-0.13.7 )
boehm-gc? ( dev-libs/boehm-gc:= )
- sdbinutils? ( sys-libs/zlib:= )
sdcdb? ( sys-libs/readline:0= )
ucsim? ( sys-libs/ncurses:= )
"
@@ -106,13 +97,13 @@ src_configure() {
local myeconfargs=(
ac_cv_prog_STRIP=true
--without-ccache
+ --enable-sdbinutils
$(use_enable ucsim)
$(use_enable device-lib)
$(use_enable packihx)
$(use_enable sdcpp)
$(use_enable sdcdb)
- $(use_enable sdbinutils)
$(use_enable non-free)
$(use_enable boehm-gc libgc)
@@ -158,7 +149,7 @@ src_compile() {
src_install() {
default
dodoc doc/*.txt
- find "${D}" -type d -name .deps -exec rm -vrf {} + || die
+ find "${ED}" -type d -name .deps -exec rm -vr {} + || die
if use doc && [[ ${PV} != "9999" ]]; then
cd "${WORKDIR}"/doc