summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-06-10 15:53:41 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-06-10 15:55:09 +0200
commit500117a04216975631baefb3545c11661de9d8bf (patch)
treeb85066ebdd1702ad7af25033dba225630410665c
parentmedia-sound/qtractor: don't automagically use Qt 6 (diff)
downloadgentoo-500117a04216975631baefb3545c11661de9d8bf.tar.gz
gentoo-500117a04216975631baefb3545c11661de9d8bf.tar.bz2
gentoo-500117a04216975631baefb3545c11661de9d8bf.zip
sys-fs/fscrypt: add 0.3.4
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--sys-fs/fscrypt/Manifest2
-rw-r--r--sys-fs/fscrypt/fscrypt-0.3.4.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-fs/fscrypt/Manifest b/sys-fs/fscrypt/Manifest
index c6b64c5f5969..d91e41743ad8 100644
--- a/sys-fs/fscrypt/Manifest
+++ b/sys-fs/fscrypt/Manifest
@@ -1,2 +1,4 @@
DIST fscrypt-0.3.3-deps.tar.xz 23310876 BLAKE2B f05ddb287e037a3f803d5c54f05abde6a19801d3ff999bda7894ba718567ac44622a1add5ce4fde6fb10e4ccec2bed87d0446e461c9deb20a6968dbf3b67429e SHA512 96367fcebb3cef56b0fb65a81e3c3d33b5980ca1bdef8d293080d709d7a22ecfe3119592e84d741b4af6e24d9e44398fad5d3f7c0d75dca1de44a13b91b6b409
DIST fscrypt-0.3.3.tar.gz 167020 BLAKE2B d271c397782bcb40cbb9d1d87463927080487898b590a83b301d98ba584fe9cb7c651c9b0c6eb905e55de42877f09367ca77593efcaca7c2441909d10190bf86 SHA512 d217212a15111bf036725f02b9530ae3716f3242e451ea5f9c8bd93cba113d9d21d1d970d9d0efaa75eb5f30a135cc6cdf18fceb8eb7d04a57363dabf4ed9fe9
+DIST fscrypt-0.3.4-deps.tar.xz 29862020 BLAKE2B 86c68888687e18bc46b791bcba4f5d08d91605d9e0397bdc94347f76c549ec9afd3f1b5030812a4eb0339a4cb6882e4db31aeb3beb543c53e7949db80adb6ceb SHA512 a406b3f4153dea04cac66bce3e0b29ec162f8dc57c3460f03489e830c43b968288d956079e22277760283bd96f7e6a8120b7bde765c4c964c8cb999871f1c04a
+DIST fscrypt-0.3.4.tar.gz 175778 BLAKE2B b8f548690fb908dd5bfbab45d70e77d773d3d46aeb89cb0f3bb397af97058f2fcf4d4d6694c66b2cefe3d5db4a0b11e9ee1a19044700183160d0d1a2917054a0 SHA512 e99ade63092281f3db948564458ddd259420bb7295c6ad896fb5e22697405aa471725c929cf98631e91c05615141c9715bce3eb1b37cbe7c07a7c7c248117b06
diff --git a/sys-fs/fscrypt/fscrypt-0.3.4.ebuild b/sys-fs/fscrypt/fscrypt-0.3.4.ebuild
new file mode 100644
index 000000000000..f7c15620c327
--- /dev/null
+++ b/sys-fs/fscrypt/fscrypt-0.3.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module pam
+
+DESCRIPTION="Tool for managing Linux filesystem encryption"
+HOMEPAGE="https://github.com/google/fscrypt"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~flow/distfiles/${PN}/${P}-deps.tar.xz
+"
+
+# Apache-2.0: fscrypt, google/renameio
+# BSD: golang/protobuf, rogpeppe/go-internal, golang/x/*
+# BSD-2: pkg/errors
+# MIT: BurntSushi/toml, kisielk/gotool, kr/*, urfave/cli, honnef.co/go/tools
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0001-Remove-TestLoadSourceDevice.patch"
+)
+
+src_compile() {
+ # Set GO_LINK_FLAGS to the empty string, as fscrypt strips the
+ # binary by default. See bug #783780.
+ emake GO_LINK_FLAGS=""
+}
+
+src_install() {
+ emake \
+ DESTDIR="${ED}" \
+ PREFIX="/usr" \
+ PAM_MODULE_DIR="$(getpam_mod_dir)" \
+ PAM_CONFIG_DIR= \
+ install
+ einstalldocs
+
+ newpamd "${FILESDIR}/fscrypt.pam-config" fscrypt
+}