summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-28 20:54:34 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-28 21:11:26 +0200
commit5002c1d31530d65a1b7c7233efc4c7a700251e9d (patch)
treeb573f780a9bdf59afe9e64a0f1d1f3d761b23898
parentdev-python/platformdirs: add 2.6.1 (diff)
downloadgentoo-5002c1d31530d65a1b7c7233efc4c7a700251e9d.tar.gz
gentoo-5002c1d31530d65a1b7c7233efc4c7a700251e9d.tar.bz2
gentoo-5002c1d31530d65a1b7c7233efc4c7a700251e9d.zip
dev-python/xxhash: add 3.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/xxhash/Manifest1
-rw-r--r--dev-python/xxhash/xxhash-3.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xxhash/Manifest b/dev-python/xxhash/Manifest
index f35f9c821333..eb61887a7efd 100644
--- a/dev-python/xxhash/Manifest
+++ b/dev-python/xxhash/Manifest
@@ -1 +1,2 @@
DIST xxhash-3.1.0.tar.gz 74389 BLAKE2B c2c7467aca51a397366c9de47104831f2d3d732b6b287e3fce4a0481d21bf059330dd63e1372b8da3aa9354efbc3de6ba106501d86c907b5783f7192e5e7c9a1 SHA512 a1d78dbbcc8fc8e41b6bc1d9e571df6951d4545fe61b198427db6f8c99058a095cf20e09951acc7bf9b432963f8b234741ae1f15ebb19972e69be0c59c9eb165
+DIST xxhash-3.2.0.tar.gz 74561 BLAKE2B d2c32b9a556eaaa67d961e130b017ff82944fbec983f24e0356436a7a23927faaba118328eff508e288e0757a1379b5ff88a48c2130eb9b3cf347e178cfc810d SHA512 bbe903b95de3e91177064986adc5c945a9b7058650ea2b5cc10ee162a15a42909dc69f95b86081b8d276960f309b4bacf895ad263a9d9188fa66bb216d76dcd5
diff --git a/dev-python/xxhash/xxhash-3.2.0.ebuild b/dev-python/xxhash/xxhash-3.2.0.ebuild
new file mode 100644
index 000000000000..dc94bedd6f45
--- /dev/null
+++ b/dev-python/xxhash/xxhash-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="
+ https://github.com/ifduyue/python-xxhash/
+ https://pypi.org/project/xxhash/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/xxhash-0.8.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests || die
+ eunittest
+}