summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-03 18:06:04 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-03 18:07:30 -0700
commit50141b75d21e644e36be4d0b010345dbb0862161 (patch)
tree571f37c3346316a923fa28c43c675179d3dbd959
parentsys-apps/systemd-tmpfiles: drop 246 (diff)
downloadgentoo-50141b75.tar.gz
gentoo-50141b75.tar.bz2
gentoo-50141b75.zip
dev-python/pydecomp: add upstream patch to avoid pixz index
Bug: https://bugs.gentoo.org/787194 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/pydecomp/files/0.3-no-pixz-index.patch55
-rw-r--r--dev-python/pydecomp/pydecomp-0.3-r2.ebuild27
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pydecomp/files/0.3-no-pixz-index.patch b/dev-python/pydecomp/files/0.3-no-pixz-index.patch
new file mode 100644
index 000000000000..0683cb12bae9
--- /dev/null
+++ b/dev-python/pydecomp/files/0.3-no-pixz-index.patch
@@ -0,0 +1,55 @@
+From 79688adff9d494e6ff412210c813d19744dbb8cd Mon Sep 17 00:00:00 2001
+From: Daniel Cordero <pydecomp@0xdc.io>
+Date: Mon, 3 May 2021 12:07:46 +0000
+Subject: [PATCH 1/2] pixz_i: copy definition from pixz
+
+---
+ DeComp/definitions.py | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/DeComp/definitions.py b/DeComp/definitions.py
+index 16114b2..14fa226 100644
+--- a/DeComp/definitions.py
++++ b/DeComp/definitions.py
+@@ -200,6 +200,14 @@ class functions do.
+ ],
+ "PIXZ", ["tar.xz", "tpxz", "xz"], {"tar", "pixz"},
+ ],
++ "pixz_i": [
++ "_common", "tar",
++ [
++ "other_options", "%(comp_prog)s", "pixz", "-cpf",
++ "%(filename)s", "-C", "%(basedir)s", "%(source)s"
++ ],
++ "PIXZ", ["tar.xz", "tpxz", "xz"], {"tar", "pixz"},
++ ],
+ "pixz_x": [
+ "_common", "tar",
+ [
+
+From f98d90a522b6d0e5331f7254bb95b057fafe44da Mon Sep 17 00:00:00 2001
+From: Daniel Cordero <pydecomp@0xdc.io>
+Date: Mon, 3 May 2021 12:12:51 +0000
+Subject: [PATCH 2/2] pixz: don't add trailing index to tarballs
+
+If pixz detects the input file is a tarball, it adds a trailing file index to help in seeking the file.
+However, this trailing index is causes decompression errors with xz -d and systemd-importd.
+
+For compatibility with these tools, force pixz to never add this tarball index.
+---
+ DeComp/definitions.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/DeComp/definitions.py b/DeComp/definitions.py
+index 14fa226..0025c07 100644
+--- a/DeComp/definitions.py
++++ b/DeComp/definitions.py
+@@ -195,7 +195,7 @@ class functions do.
+ "pixz": [
+ "_common", "tar",
+ [
+- "other_options", "%(comp_prog)s", "pixz", "-cpf",
++ "other_options", "%(comp_prog)s", "'pixz -t'", "-cpf",
+ "%(filename)s", "-C", "%(basedir)s", "%(source)s"
+ ],
+ "PIXZ", ["tar.xz", "tpxz", "xz"], {"tar", "pixz"},
diff --git a/dev-python/pydecomp/pydecomp-0.3-r2.ebuild b/dev-python/pydecomp/pydecomp-0.3-r2.ebuild
new file mode 100644
index 000000000000..8a9c3672f84a
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-0.3-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PV}-no-pixz-index.patch" )