summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-02-27 01:15:11 +0300
committerMichał Górny <mgorny@gentoo.org>2023-02-27 20:31:32 +0100
commit5029513890ed8905d8f3028460479abdcba97b43 (patch)
tree9abda32fb06efea9c1c17a95b15fcc32f72eb32e
parentsci-astronomy/kstars: drop 3.6.1 (diff)
downloadgentoo-50295138.tar.gz
gentoo-50295138.tar.bz2
gentoo-50295138.zip
dev-python/toposort: 1.10 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/29816 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/toposort/Manifest1
-rw-r--r--dev-python/toposort/toposort-1.10.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/toposort/Manifest b/dev-python/toposort/Manifest
index e0352e8e82f3..faa359912380 100644
--- a/dev-python/toposort/Manifest
+++ b/dev-python/toposort/Manifest
@@ -1 +1,2 @@
DIST toposort-1.9.tar.gz 10878 BLAKE2B fc2f6543ae74ea6e448ffe2be4e47438842b5ba95eac2f45fcc8d72e682054af0b80a0d453c5afaebeb1c9881d6874ab16ea523b19aad589545c8aae0b8cf255 SHA512 ec86f59f5e61b6d1c783965095f71693306a83a8b54a0661cddb3c51a5e2f9314075b453a901b5e3664b77d9e047901120622dbc23d642269a9546f41395388a
+DIST toposort-1.10.tar.gz 11132 BLAKE2B 373c9549cb5e64d2636fe8bd67d73a8eeab671243b562654660bc59c2ceddc4196fad3882bd68d873647ddf504a6c90174b5c995dbd7c8e457744b4daceaa099 SHA512 7578706b2b383f4e1c7228aebc2f590ec51953e36d594572d494bc928d4f207da7419a9b662a2f77426347f49d33f355f67f45e28226a7e4546d6c16c743dc4e
diff --git a/dev-python/toposort/toposort-1.10.ebuild b/dev-python/toposort/toposort-1.10.ebuild
new file mode 100644
index 000000000000..b42a68d9b06f
--- /dev/null
+++ b/dev-python/toposort/toposort-1.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a topological sort algorithm"
+HOMEPAGE="
+ https://gitlab.com/ericvsmith/toposort/
+ https://pypi.org/project/toposort/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test/test_toposort.py -v || die "Tests failed with ${EPYTHON}"
+}