summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-04 12:04:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-04 12:05:15 -0800
commit50366cf3a9c867e9eda9b61ae90f988d2a18c171 (patch)
tree26f3ac69e8ff7bc45fad2ec3f106086a9b5e3115
parentdev-python/secretstorage-3.1.1-r1: revbump, add py38, use distutils-r1 helpers (diff)
downloadgentoo-50366cf3a9c867e9eda9b61ae90f988d2a18c171.tar.gz
gentoo-50366cf3a9c867e9eda9b61ae90f988d2a18c171.tar.bz2
gentoo-50366cf3a9c867e9eda9b61ae90f988d2a18c171.zip
dev-python/keyring-19.3.0: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/files/keyring-19.3.0-tests.patch26
-rw-r--r--dev-python/keyring/keyring-19.3.0.ebuild61
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 4d353aab8417..9f03fcc22f7f 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -2,3 +2,4 @@ DIST keyring-13.2.1.tar.gz 43140 BLAKE2B 74272b93ff80a03615879a5f416ad6be1012f22
DIST keyring-15.0.0.tar.gz 42547 BLAKE2B b9200f61fcf227ce82ed05db15b8a03754a2d2f0ee7a32afe4a99a6bb4c511e311d7c529d5173756173622e225ae4fa2fcef6409b21dc3d8735b5e8fab73bd1a SHA512 58001d61bdd442196ec4891000cc532d1dd9b85b18d100d8dde38cf1cf733ef6d6541513d73435dfe41e9cd26c6e34332d518a06a7fbc498b1b8971df6640212
DIST keyring-18.0.1.tar.gz 48559 BLAKE2B fb9e8df5ae04b4c1d646b4129cf34d420fd05783724dc2d10fccfaf11ddf1a17048c2695477bc1f4cfcd6d08ed48b6d552d19862a0510d8e12fef4e17b13087b SHA512 62091fc304ff0d4a1dd5db3e1fbae7e02edcb60442f19d7408ba2f115226a8282ff67df55334f019da3cccae858cd5e4b0c0ece22a7c66768bbb85018728be30
DIST keyring-19.2.0.tar.gz 41728 BLAKE2B 24a8f095f4009f37fa6d5e7bc2b12be816a5db2abfa4416fc18203a818296c775fe34a2936a71b191700ad511e01059974aec374aea5ee312507a27bd8be76b8 SHA512 5104423289b9e537e64760afed38e5851766b9c955c0659b078cdaba82813e93922e488b5465157cb930285416feef07c0b559fc49909f58bc85b6f30d55dd75
+DIST keyring-19.3.0.tar.gz 43587 BLAKE2B a1003aa55ac48f39e84431c50fe3e24e1da76a0db177eed08bd2c2110b78d10cbfcf7188519435732be68452a0318119cca1563168410b16fc529a3a7e98125c SHA512 b1d26f665203b11712ef91057ecd78cce58b35038b259605c42997283f6c41449baf242ecf43510b29598559b8aecf733eb66be6e0c439564256f40eb0f6982c
diff --git a/dev-python/keyring/files/keyring-19.3.0-tests.patch b/dev-python/keyring/files/keyring-19.3.0-tests.patch
new file mode 100644
index 000000000000..82cef178c6cb
--- /dev/null
+++ b/dev-python/keyring/files/keyring-19.3.0-tests.patch
@@ -0,0 +1,26 @@
+diff --git a/keyring/tests/test_multiprocess.py b/keyring/tests/test_multiprocess.py
+index 49af222..8fdd1a3 100644
+--- a/keyring/tests/test_multiprocess.py
++++ b/keyring/tests/test_multiprocess.py
+@@ -11,6 +11,11 @@ def subprocess_get():
+ keyring.get_password('test_app', 'test_user')
+
+
++pytestmark = pytest.mark.xfail(
++ platform.system() == 'Linux', reason="#410: keyring discovery fails intermittently"
++)
++
++
+ def test_multiprocess_get():
+ proc1 = multiprocessing.Process(target=subprocess_get)
+ proc1.start()
+@@ -23,9 +28,6 @@ def test_multiprocess_get():
+ sys.version_info < (3, 8) and platform.system() == 'Darwin',
+ reason="#281: Prior to 3.8, multiprocess invocation fails",
+ )
+-@pytest.mark.xfail(
+- platform.system() == 'Linux', reason="#410: tests fail intermittently"
+-)
+ def test_multiprocess_get_after_native_get():
+ keyring.get_password('test_app', 'test_user')
+ test_multiprocess_get()
diff --git a/dev-python/keyring/keyring-19.3.0.ebuild b/dev-python/keyring/keyring-19.3.0.ebuild
new file mode 100644
index 000000000000..73c4ca0d8931
--- /dev/null
+++ b/dev-python/keyring/keyring-19.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/secretstorage[${PYTHON_USEDEP}]
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{5,6,7})
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/keyring-19.1.0-tests.patch"
+ # https://github.com/jaraco/keyring/commit/411204df606bdf02c99f3360ec033e3c235d5f67
+ "${FILESDIR}/keyring-19.3.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/jaraco-packaging \
+ dev-python/rst-linker
+
+python_prepare_all() {
+ # avoid setuptools_scm and a bunch of style checker dependencies
+ sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
+ sed -r \
+ -e "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
+ -e "/pytest-checkdocs/ d" \
+ -e "/pytest-flake8/ d" \
+ -e "/pytest-black-multipy/ d" \
+ -e "/pytest-cov/ d" \
+ -i setup.cfg || die
+
+ # avoid other deps
+ local -a pytest_params=(doctest-modules flake8 black cov)
+ sed -r -e "$(printf -- 's:[[:space:]]*--%s:: ;' "${pytest_params[@]}")" \
+ -i pytest.ini || die
+
+ rm ${PN}/tests/backends/test_kwallet.py || die
+
+ distutils-r1_python_prepare_all
+}