summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:16:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 07:26:50 +0200
commit503daf69c241e29611e581304566f0c57a955600 (patch)
tree947a7aea041c2c6f0bd47a89bb22979410a2a319
parentdev-lang/julia-bin: drop 1.6.3 (diff)
downloadgentoo-503daf69c241e29611e581304566f0c57a955600.tar.gz
gentoo-503daf69c241e29611e581304566f0c57a955600.tar.bz2
gentoo-503daf69c241e29611e581304566f0c57a955600.zip
dev-python/apsw: Bump to 3.38.5_p1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.38.5_p1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 515a5c8add95..bd103e7bd982 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.38.1-r1.gh.tar.gz 338985 BLAKE2B aa0ef335bd3abc708b41a92959f98b4fd3961168feacb9ca6d382e0279c46d4227a8e09373721ae1361fcc38181376664130b3623b2f36e1596467b99959ecb8 SHA512 4d161641d7bf7f933507e7d7e71d437d9db95f7327e29cf34848d9b741e2711dafbefbf19cb34d78d83b4e69115acad855f924fdf80de1cea4c9d61fe0f2b670
+DIST apsw-3.38.5-r1.gh.tar.gz 338186 BLAKE2B 145e38d4057be498f85a655ad7a437ec19a895769f58505b4b99093be30e67498faf9572494009db8e20e6700fa5e514605af131d045a4e8bb41587b828f5a88 SHA512 58331ca2db993f87316a55075ee9c440d4bd6e985e8ca11079391bd9cc2a907271ffe5c21d66840e336cd9e6568f6134c8b8fa5d28bbc7c77a1dddd48e8b99b7
diff --git a/dev-python/apsw/apsw-3.38.5_p1.ebuild b/dev-python/apsw/apsw-3.38.5_p1.ebuild
new file mode 100644
index 000000000000..737f556a79f7
--- /dev/null
+++ b/dev-python/apsw/apsw-3.38.5_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%_p*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+)
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}