summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-12-02 22:21:24 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-12-02 22:22:44 +0100
commit504ad285e2f64861207ad68eca72d96d40ce0c41 (patch)
treee707812d62dbf390bae8b804f7ee642422a4f485
parentsys-auth/AusweisApp2: bump to version 1.22.0 (diff)
downloadgentoo-504ad285.tar.gz
gentoo-504ad285.tar.bz2
gentoo-504ad285.zip
app-emulation/pcem: bump to version 17
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-emulation/pcem/Manifest1
-rw-r--r--app-emulation/pcem/files/pcem-17-respect-cflags.patch13
-rw-r--r--app-emulation/pcem/pcem-17.ebuild77
3 files changed, 91 insertions, 0 deletions
diff --git a/app-emulation/pcem/Manifest b/app-emulation/pcem/Manifest
index 3129bda1758a..eb463379e2e2 100644
--- a/app-emulation/pcem/Manifest
+++ b/app-emulation/pcem/Manifest
@@ -1 +1,2 @@
DIST PCemV16Linux.tar.gz 1859892 BLAKE2B e388031e661b9320cc783e6400bdb7c191a2f946d9c207d9a58daa9270115b32ed55ac6a0b87227b51d10168e7d161bb03811eb83f5405ed1a71f7bfc6fd8aa5 SHA512 97d33ae1c4b59f281abe553ed4297c0d6c3956cf32b44474bfd5773700dd5c4ea6c209c679b9add5d4a7cba61748ee9794afa3c59af3230fa2a15812e13fd1c5
+DIST PCemV17Linux.tar.gz 1880868 BLAKE2B 64068f0f98e8fe3e9bfe42a04f462375a7ee0cb8259b103237f3b0542f54ad13ed625a55c8379e2c54a87348ed504496a6b163419855ceeda8e4f18e1ea5dcd9 SHA512 6d84c8cbe9b6116f6439f542ac08139cfc5652a34b615a1ed841a6f8c227e77f1d26573ec35d57511b9a69e7472fbe51f2abb9307f8f8c1207c74fbe8107cadd
diff --git a/app-emulation/pcem/files/pcem-17-respect-cflags.patch b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
new file mode 100644
index 000000000000..73cac4541bf1
--- /dev/null
+++ b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,8 +31,8 @@
+ CXXFLAGS="-Wall -O0 -g -D_DEBUG -fcommon"
+ AC_MSG_RESULT([yes])
+ else
+- CFLAGS="-O3 -fcommon"
+- CXXFLAGS="-O3 -fcommon"
++ CFLAGS?="-O3 -fcommon"
++ CXXFLAGS?="-O3 -fcommon"
+ AC_MSG_RESULT([no])
+ fi
+
diff --git a/app-emulation/pcem/pcem-17.ebuild b/app-emulation/pcem/pcem-17.ebuild
new file mode 100644
index 000000000000..825619a6ac61
--- /dev/null
+++ b/app-emulation/pcem/pcem-17.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic wxwidgets
+
+WX_GTK_VER="3.0-gtk3"
+
+DESCRIPTION="A PC emulator that specializes in running old operating systems and software"
+HOMEPAGE="
+ https://pcem-emulator.co.uk/
+ https://github.com/sarah-walker-pcem/pcem/
+"
+SRC_URI="https://pcem-emulator.co.uk/files/PCemV${PV}Linux.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa networking"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsdl2
+ media-libs/openal
+ x11-libs/wxGTK:${WX_GTK_VER}[tiff,X]
+"
+
+DEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "TESTED.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-17-respect-cflags.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Does not compile with -fno-common.
+ # See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
+ append-cflags -fcommon
+
+ local myeconfargs=(
+ --enable-release-build
+ $(use_enable alsa)
+ $(use_enable networking)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/pcem
+ doins -r configs nvr roms
+
+ newicon src/icons/32x32/motherboard.png pcem.png
+ make_desktop_entry "pcem" "PCem" pcem "Development;Utility"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to use PCem, you will need some roms for various emulated systems."
+ elog "You can either install globally for all users or locally for yourself."
+ elog ""
+ elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
+ elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
+}