summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-11-15 08:28:30 -0800
committerSam James <sam@gentoo.org>2023-11-17 12:31:24 +0000
commit504b2006657ab56aae7a79179e3a5a037072da10 (patch)
tree8527482f0136221ce281f15cd13dc20ae951acee
parentsys-devel/slibtool: add missing keywords for the live ebuild (diff)
downloadgentoo-504b2006657ab56aae7a79179e3a5a037072da10.tar.gz
gentoo-504b2006657ab56aae7a79179e3a5a037072da10.tar.bz2
gentoo-504b2006657ab56aae7a79179e3a5a037072da10.zip
sys-devel/slibtool: add 0.5.35
Closes: https://bugs.gentoo.org/780054 Upstream-Commit: https://dev.midipix.org/cross/slibtool/c/5e02698d061d467abbf21ff857e9862e37060f89 Closes: https://bugs.gentoo.org/789804 Upstream-Commit: https://dev.midipix.org/cross/slibtool/c/a126a7f68ef374d65d014226195380eb7dceb634 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/33846 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/slibtool/Manifest2
-rw-r--r--sys-devel/slibtool/slibtool-0.5.35.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/slibtool/Manifest b/sys-devel/slibtool/Manifest
index 0a7b2da67762..0eb5c9adef83 100644
--- a/sys-devel/slibtool/Manifest
+++ b/sys-devel/slibtool/Manifest
@@ -1,2 +1,4 @@
DIST slibtool-0.5.34.tar.xz 79720 BLAKE2B 3a692d7485dcf2277f7ed99fe1ad67cf5fd33d8fe0a527d64634b0e7f956a5f58b92d812396f00d872ceb8509e058ae1a026f16a65feb2e79a9fff7bd60290da SHA512 3f7f6e4f45c4c2ae5ba5533152f08269cd77ca6fa2f3a515802bc23c7ac505b2d7340098fa98962c79035129cfd4077205596309f4acd1d634b9a1d6e2c0e96c
DIST slibtool-0.5.34.tar.xz.sig 833 BLAKE2B 52df017d8ae3056e259a5283b0a4cea119a5ab4ce95e6c894d0d2e98fc10db101039a57c9a2a771f677c9d0afaad9273095ebdb078fca146a3d67ea25e9261fb SHA512 9f8415431a0b43e7be9a808dd6ed138a9b34b7b2c4af3ab406bdbc456ec31c877f13bc0b056ab9a50bec0b0cf1b654a133085f8523e70c8cb7d3851652d34ff7
+DIST slibtool-0.5.35.tar.xz 87964 BLAKE2B cd01e3dc479cde2ffd8b58c51273b6c6f503056f009aa960b79dd0a6d2d18c73a3dfd9eb7933f24fd47ff849911cb63ca014eadd2bf661e3c0236467eb0802ff SHA512 e1d2f03596432f970f8c1f93d4387cafb11355a520fb5adb9bbc02f3dcdea0bbb78ca6fe84c24faebee848279050c5bec13fd64a168b12d7fc885ac9d31a7560
+DIST slibtool-0.5.35.tar.xz.sig 833 BLAKE2B 597d5beb51f650643f1ef1c8f576200ccda154e9428e5097c2236e8d71992a4c9c39d44c1325f9f1265e1cfa49f08581546c0b0f8019c7796ce9271219480753 SHA512 2a7333997802ef56a57bf32fbfce17030c1dd732c9066bec94d0719cbda3dc85e896a0221e43065fc3ed35ee852942a5f7c270d56276706b9f0fdb7f4d091ef8
diff --git a/sys-devel/slibtool/slibtool-0.5.35.ebuild b/sys-devel/slibtool/slibtool-0.5.35.ebuild
new file mode 100644
index 000000000000..e3bff0c2818a
--- /dev/null
+++ b/sys-devel/slibtool/slibtool-0.5.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# git.foss21.org is the official repository per upstream
+DESCRIPTION="A skinny libtool implementation, written in C"
+HOMEPAGE="https://git.foss21.org/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.foss21.org/slibtool"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/midipix.asc
+ inherit verify-sig
+
+ SRC_URI="https://dl.midipix.org/slibtool/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( https://dl.midipix.org/slibtool/${P}.tar.xz.sig )"
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-midipix )"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # Custom configure script (not generated by autoconf)
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --host=${CHOST} \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ || die
+}