summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-02-24 23:31:24 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-02-24 23:35:18 +0100
commit5059bb531cc73e428042a83fe07191b2d98d40c4 (patch)
tree50b0c2647c85d761a913c386c091f92bd99d6a2d
parentwww-client/firefox: check-reqs also in pkg_setup() (diff)
downloadgentoo-5059bb53.tar.gz
gentoo-5059bb53.tar.bz2
gentoo-5059bb53.zip
www-client/firefox: block USE=pgo when USE=-clang
USE=pgo is currently known to be broken when using GCC. Instead of silently ignoring USE=pgo when using GCC, we are forcing a user decision so user has the chance to enable USE=clang in case PGO is important for user without wasting 2+ hours commpiling firefox just to find out that PGO which was requested was ignored. Bug: https://bugs.gentoo.org/709594 Bug: https://bugs.gentoo.org/709654 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/firefox-73.0.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-73.0.1.ebuild b/www-client/firefox/firefox-73.0.1.ebuild
index a9232b0afb23..106e5b996ea3 100644
--- a/www-client/firefox/firefox-73.0.1.ebuild
+++ b/www-client/firefox/firefox-73.0.1.ebuild
@@ -209,6 +209,14 @@ pkg_pretend() {
if ! has usersandbox $FEATURES ; then
die "You must enable usersandbox as X server can not run as root!"
fi
+
+ if ! use clang ; then
+ # Force user decision so they don't find out firefox was build
+ # without pgo after spending some hours
+ eerror "USE=pgo when using GCC is currently known to be broken."
+ eerror "Either switch to USE=clang or temporarily set USE=-pgo."
+ die "USE=pgo without USE=clang is currently known to be broken."
+ fi
fi
# Ensure we have enough disk space to compile