summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-09 07:40:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-09 08:01:30 +0200
commit50984d548871af48cfd28a53306f6a34644c1e58 (patch)
tree8f52e939c51c03ea508c1cbfccc03db56ef465ce
parentdev-python/jupyterlab: Bump to 4.1.6 (diff)
downloadgentoo-50984d548871af48cfd28a53306f6a34644c1e58.tar.gz
gentoo-50984d548871af48cfd28a53306f6a34644c1e58.tar.bz2
gentoo-50984d548871af48cfd28a53306f6a34644c1e58.zip
dev-python/jupyterlab-server: Bump to 2.26.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyterlab-server/Manifest1
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.26.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
index f5843cca370d..3865e8c202e7 100644
--- a/dev-python/jupyterlab-server/Manifest
+++ b/dev-python/jupyterlab-server/Manifest
@@ -1 +1,2 @@
DIST jupyterlab_server-2.25.4.tar.gz 74772 BLAKE2B 8647840e2bb93244360db07524374f30e6831fddf6c2b89101b2a01f505470649fcc6aa31b40dc18a480628eeb791b4f7488cd91bb921796c3daad36102e535b SHA512 de04d1c5de3507a2465c316686be10ff6398be2f05d9d84ff6e79c376978503bc6ff836bfca67735d85f8ef23a15d6f30ad69268a25855dc4ebc1bd5f7c2fdaf
+DIST jupyterlab_server-2.26.0.tar.gz 75100 BLAKE2B 10f507cf8b6640ee4178d2850561a5d186f9b9004b2d74de7382b4c9a03494d3553e7a2397cafb45b3be60062baf0d3df3026b1f8613e5dd2a597faad0cfc9d5 SHA512 cb9c78ae8afed53637b441767c630666d391a7ce6a19cc5cf8bcc9c3149ef570c5aeaba204878bd4d52806a6e2b9e25f9724536f1addf084bfb15855f7700125
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.26.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.26.0.ebuild
new file mode 100644
index 000000000000..023800f2076e
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.26.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.19[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.18[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin -p timeout
+}