summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-28 03:14:21 +0000
committerSam James <sam@gentoo.org>2023-02-28 03:14:21 +0000
commit509d54b8b3f926ed718bd97920b4bcc7e2238f41 (patch)
treed2c28760e6195f77b07d0349de92312f71ef3e4e
parentsys-kernel/linux-headers: Stabilize 6.1 arm, #898202 (diff)
downloadgentoo-509d54b8.tar.gz
gentoo-509d54b8.tar.bz2
gentoo-509d54b8.zip
sys-apps/portage: backport QA notice improvement
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/portage/files/portage-3.0.45.1-qa-notice-configure-func-decl.patch29
-rw-r--r--sys-apps/portage/portage-3.0.45.1-r2.ebuild (renamed from sys-apps/portage/portage-3.0.45.1-r1.ebuild)1
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/portage/files/portage-3.0.45.1-qa-notice-configure-func-decl.patch b/sys-apps/portage/files/portage-3.0.45.1-qa-notice-configure-func-decl.patch
new file mode 100644
index 000000000000..a621ab65d719
--- /dev/null
+++ b/sys-apps/portage/files/portage-3.0.45.1-qa-notice-configure-func-decl.patch
@@ -0,0 +1,29 @@
+From eca90b6049a9ce42ec6868f64abcab403c9f4190 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 28 Feb 2023 03:10:26 +0000
+Subject: [PATCH] install-qa-check.d/90config-impl-decl: prefix warning with
+ 'QA Notice'
+
+... so tinderboxes can pick it up more easily.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/bin/install-qa-check.d/90config-impl-decl
++++ b/bin/install-qa-check.d/90config-impl-decl
+@@ -92,12 +92,13 @@ config_impl_decl_check() {
+ # Drop out early if no impl decls found (all the arrays are the same size)
+ [[ ${#files[@]} -eq 0 ]] && return
+
+- eqawarn 'Found the following implicit function declarations in configure logs:'
++ eqawarn 'QA Notice: Found the following implicit function declarations in configure logs:'
+ for l in "${!files[@]}"; do
+ eqawarn " ${files[l]}:${lines[l]} - ${funcs[l]}"
+ eqatag 'config.log-impl-decl' "line=${lines[l]}" "func=${funcs[l]}" "${files[l]}"
+ done
+ eqawarn 'Check that no features were accidentally disabled.'
++ eqawarn 'See https://wiki.gentoo.org/wiki/Modern_C_porting.'
+ }
+
+ config_impl_decl_check
+--
+2.39.2
+
diff --git a/sys-apps/portage/portage-3.0.45.1-r1.ebuild b/sys-apps/portage/portage-3.0.45.1-r2.ebuild
index c226bd813658..b345f442048e 100644
--- a/sys-apps/portage/portage-3.0.45.1-r1.ebuild
+++ b/sys-apps/portage/portage-3.0.45.1-r2.ebuild
@@ -90,6 +90,7 @@ pkg_pretend() {
python_prepare_all() {
local PATCHES=(
+ "${FILESDIR}"/${P}-qa-notice-configure-func-decl.patch
)
distutils-r1_python_prepare_all