summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-28 14:01:12 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-28 14:21:29 -0800
commit50ae616a02e04e94e5824cacb1f94d8389e6895e (patch)
tree36c23e1476882a2c950cdc4d20b10278851be4b1
parentdev-python/grpcio-tools: add 1.51.0 (diff)
downloadgentoo-50ae616a.tar.gz
gentoo-50ae616a.tar.bz2
gentoo-50ae616a.zip
dev-python/grpcio-testing: add 1.51.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/grpcio-testing/Manifest1
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/Manifest b/dev-python/grpcio-testing/Manifest
index 8b74ea0fc289..56dc95a6fa63 100644
--- a/dev-python/grpcio-testing/Manifest
+++ b/dev-python/grpcio-testing/Manifest
@@ -1 +1,2 @@
DIST grpcio-testing-1.43.0.tar.gz 17693 BLAKE2B f75158a870b63c48d19e849f87e4682c13a1d500690ff0f39d0d609c3de2f3086765dc7fe15acd590667fcc8ab8ce5d149517be5cbbb685bc222619b23e367a8 SHA512 4ad3da7805e85c0869c5a8c992d1512942334edeef10812665bdfb4a81b3d07efff08686b93c501f43d12e0c6181717ddbea392f1751a229d7a5fe26f162fae2
+DIST grpcio-testing-1.51.0.tar.gz 22390 BLAKE2B 813ade1f3f44e3aeda7ca779f130897281036de111cb17f9297f267961a591e1fa3b88380ccbec42edd339487f1b3f1028dcd308c46ffd8fde5817e3909cfd41 SHA512 3fd9de9cd75aebcf1f6c3716bbacaf5cc9cc9aa74acb42dd128b5c158fa2d52549cdcc8f3ea9f2cb0b86d0b84c998acd55fa16e879ac9099a2348d889d35d837
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild
new file mode 100644
index 000000000000..b65b69efba23
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.51.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-4.21.3[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"