summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-31 03:28:45 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-31 03:28:45 -0700
commit50b459eb9fd61a4853d981e8e0d5b11fdf01e6eb (patch)
tree72242cc7897073156c41306beb05a72d9573fa87
parentwww-plugins/passff-host: enable py3.10 (diff)
downloadgentoo-50b459eb9fd61a4853d981e8e0d5b11fdf01e6eb.tar.gz
gentoo-50b459eb9fd61a4853d981e8e0d5b11fdf01e6eb.tar.bz2
gentoo-50b459eb9fd61a4853d981e8e0d5b11fdf01e6eb.zip
www-plugins/passff-host: drop 1.2.1-r1
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--www-plugins/passff-host/Manifest2
-rw-r--r--www-plugins/passff-host/passff-host-1.2.1-r1.ebuild59
2 files changed, 0 insertions, 61 deletions
diff --git a/www-plugins/passff-host/Manifest b/www-plugins/passff-host/Manifest
index a71c12dfafbe..a9d55db5e561 100644
--- a/www-plugins/passff-host/Manifest
+++ b/www-plugins/passff-host/Manifest
@@ -1,4 +1,2 @@
-DIST passff-host-1.2.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
-DIST passff-host-1.2.1.py 3666 BLAKE2B 6a95defc3b1abe91f95e83ab20e9d0e533da2ae0e2153d2b50abf0a77aeb426b6b0a0ed042c00912a434dadbf53a9091fa772df9b9f5c330982a9ab49b891bc8 SHA512 5fe848fe0d6a75b679ee18fd5d32fda963853b91ad382fc19780104d44d1052a7191188946af470722dab883f0318ec38980fc24f052aeb5c54cac98f810ee15
DIST passff-host-1.2.2.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
DIST passff-host-1.2.2.py 3691 BLAKE2B 3fb64c6ca0d512d61f7bd3884ff5714f5a1b93095ab1c99043645d8253b5128d3d054faec6bff0f560f536b10ffa1cd523dc440b19d90cfff3bac6009f0ce86e SHA512 407be35359e987f355f04a45bf8a0c1023ee04d3c6d7c4ea9cce29955957cd514302ca04aeda4367e8560e8d765159b5fddad2e51ea089f9eb2947564605b5cf
diff --git a/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild b/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild
deleted file mode 100644
index df908c998abd..000000000000
--- a/www-plugins/passff-host/passff-host-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2018-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-single-r1
-
-DESCRIPTION="Host app for the PassFF WebExtension"
-HOMEPAGE="https://github.com/passff/passff-host"
-
-SRC_URI="
- https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
- https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="chrome chromium +firefox vivaldi"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- || ( chrome chromium firefox vivaldi )
-"
-
-RDEPEND="${PYTHON_DEPS}"
-
-S="${WORKDIR}"
-
-src_unpack() {
- cp "${DISTDIR}/${P}.json" . || die
- cp "${DISTDIR}/${P}.py" . || die
-}
-
-src_prepare() {
- default
- python_fix_shebang "${P}.py"
-}
-
-src_install() {
- local target_dirs=()
-
- use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
- use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
- use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
- # www-client/firefox-bin compile-time dir is under /usr/lib/
- use firefox && target_dirs+=( "/usr/lib/mozilla/native-messaging-hosts" )
- use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
-
- for target_dir in "${target_dirs[@]}"; do
- sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
-
- insinto "${target_dir}"
- doins passff.json
- exeinto "${target_dir}"
- newexe "${P}.py" passff.py
- done
-}