summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-02 14:24:48 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-02 14:28:02 +0200
commit50b612131a7ff349a7b0487ddd44189d8918a5c2 (patch)
treee3d8654aa24172c4f94a733d6c81ca047d8f86bf
parentdev-perl/Net-HTTP: alpha/amd64/arm/hppa/ia64/ppc64/ppc/sparc/x86 stable, (ALL... (diff)
downloadgentoo-50b61213.tar.gz
gentoo-50b61213.tar.bz2
gentoo-50b61213.zip
net-libs/rest: Stop relying on libsoup-gnome
Package-Manager: portage-2.2.28
-rw-r--r--net-libs/rest/rest-0.7.93-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/rest/rest-0.7.93-r1.ebuild b/net-libs/rest/rest-0.7.93-r1.ebuild
new file mode 100644
index 000000000000..ad507b8c028c
--- /dev/null
+++ b/net-libs/rest/rest-0.7.93-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Helper library for RESTful services"
+HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
+
+LICENSE="LGPL-2.1"
+SLOT="0.7"
+IUSE="+introspection test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Coverage testing should not be enabled
+RDEPEND="
+ app-misc/ca-certificates
+ >=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
+ dev-libs/libxml2:2[${MULTILIB_USEDEP}]
+ net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+ # gnome support only adds dependency on obsolete libsoup-gnome
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758166
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --disable-static \
+ --disable-gcov \
+ --without-gnome \
+ --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
+ $(multilib_native_use_enable introspection)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
+ fi
+}
+
+multilib_src_test() {
+ # Tests need dbus
+ Xemake check
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}