summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-10-04 08:04:25 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-10-04 08:40:20 +0300
commit50c00e7dd00ac1280ed9cb4636f2dd531f6bb993 (patch)
treec1cefb29b4ccd55894c1d84d36ab318e462ad259
parentx11-terms/xterm: add 369 (diff)
downloadgentoo-50c00e7dd00ac1280ed9cb4636f2dd531f6bb993.tar.gz
gentoo-50c00e7dd00ac1280ed9cb4636f2dd531f6bb993.tar.bz2
gentoo-50c00e7dd00ac1280ed9cb4636f2dd531f6bb993.zip
x11-terms/terminology: add 1.10.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.10.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index d1dc9f5e1da1..b99acec79451 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
+DIST terminology-1.10.0.tar.xz 4984496 BLAKE2B f8ca3e30686057a95d3d37993680e436c30df64fa058ebfdc5faeb2c4695b1e7277a542c4d92870d89e006db408b93b1cc99f1d2d5037023b1525662ab95192d SHA512 2afd253da27a49bf4d306bcc92fb14148c7f2df1116de8422a60be128be8483042ae61457805ce446d863b5671c6d1613d77efc811167a786f3968f68964dae1
DIST terminology-1.9.0.tar.xz 4971192 BLAKE2B 840da3f9c5432d795fc21418b24a351e6c3057566339c673c2de7c08ff16db9d65cbb431ac1151cb85f035a577b509339fbf6eed68197ac96d67dd59c6a67cb1 SHA512 03955899f320b9d018d9e8a4a195b298e35052e6b5fa7d6c804f1810edf9ef55cac02e8d8c7261e1b890e8a453fce6418dc53a37abe499067688d3e16fdff9f1
diff --git a/x11-terms/terminology/terminology-1.10.0.ebuild b/x11-terms/terminology/terminology-1.10.0.ebuild
new file mode 100644
index 000000000000..9ba5779041f8
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson python-any-r1 xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[gles2-only] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}