summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-21 06:56:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-21 07:21:46 +0100
commit50eb0a2b521d49be2a21f7b6f1995990316efe99 (patch)
tree31fa79e0cefc4778495416dd92721b625dfbf60a
parentdev-python/pdm: Bump to 2.12.2 (diff)
downloadgentoo-50eb0a2b521d49be2a21f7b6f1995990316efe99.tar.gz
gentoo-50eb0a2b521d49be2a21f7b6f1995990316efe99.tar.bz2
gentoo-50eb0a2b521d49be2a21f7b6f1995990316efe99.zip
dev-python/pip-run: Bump to 12.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pip-run/Manifest1
-rw-r--r--dev-python/pip-run/pip-run-12.5.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pip-run/Manifest b/dev-python/pip-run/Manifest
index 7c01fe8f2134..5ab883e93703 100644
--- a/dev-python/pip-run/Manifest
+++ b/dev-python/pip-run/Manifest
@@ -1 +1,2 @@
DIST pip-run-12.4.0.tar.gz 37749 BLAKE2B 76e6708cbcb9329b42ac031ee8f2253f04f898a8d6c83ae687f3a7f6e13f33076fdadad641562f379a5cdad1386cb71bf1b40f494c484f86286d1188f86c04ad SHA512 4e6709b2e22b49a3486f4d1caa07ae3d664b09bf76c9338ef8c9fb80024700fcd58c135d3cf3b69e7fcbf1ce20c996436fa87be03fbe9f5801b274ff72a4a790
+DIST pip-run-12.5.0.tar.gz 38695 BLAKE2B a44d35752586bd6d27a2d7e7feebbf904f8552e11becd821e693716b1ef74bfb490a17aacf3b7c19656bbc21fde38e40d29c79a611b2f510c02d199afc8f5cb1 SHA512 b641633c1863745d31637b1ef2a9151c79cc0c647b1bc246dbea5e834ec928b11b29b9cee1952513340bacb1ead610c2b34426b54d76345b57c887b1fe4b68d6
diff --git a/dev-python/pip-run/pip-run-12.5.0.ebuild b/dev-python/pip-run/pip-run-12.5.0.ebuild
new file mode 100644
index 000000000000..18908d5d7407
--- /dev/null
+++ b/dev-python/pip-run/pip-run-12.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Install packages and run Python with them"
+HOMEPAGE="
+ https://github.com/jaraco/pip-run/
+ https://pypi.org/project/pip-run/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-env[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.7[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/path[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/platformdirs[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ dev-python/jaraco-path[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.3[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -m "not network"
+}