summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-29 20:00:46 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-29 20:00:46 +0200
commit50ff91c46c7b545e958440f95d8dc307e4c1ca55 (patch)
treef4fd934ad1fe72fcc13487cd45910cf9cda6b5e9
parentdev-embedded/xa: Keyword 2.3.13 arm64, #861008 (diff)
downloadgentoo-50ff91c46c7b545e958440f95d8dc307e4c1ca55.tar.gz
gentoo-50ff91c46c7b545e958440f95d8dc307e4c1ca55.tar.bz2
gentoo-50ff91c46c7b545e958440f95d8dc307e4c1ca55.zip
dev-libs/redland: update EAPI 7 -> 8
Bug: https://bugs.gentoo.org/382691 Bug: https://bugs.gentoo.org/843074 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/redland/files/redland-1.0.17-ldflags-pc-leak.patch24
-rw-r--r--dev-libs/redland/redland-1.0.17-r3.ebuild83
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/redland/files/redland-1.0.17-ldflags-pc-leak.patch b/dev-libs/redland/files/redland-1.0.17-ldflags-pc-leak.patch
new file mode 100644
index 000000000000..6fbb121c29a7
--- /dev/null
+++ b/dev-libs/redland/files/redland-1.0.17-ldflags-pc-leak.patch
@@ -0,0 +1,24 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu May 2 14:25:04 UTC 2013
+Subject: ldflags have no place in pkgconfig files
+
+--- a/redland.pc.in
++++ b/redland.pc.in
+@@ -14,5 +14,5 @@
+ Requires.private: raptor2 >= @RAPTOR_MIN_VERSION@, rasqal >= @RASQAL_MIN_VERSION@, rasqal <= @RASQAL_MAX_VERSION@
+ Version: @VERSION@
+ Libs: -L${libdir} -lrdf
+-Libs.private: @LIBRDF_LDFLAGS@ @LIBRDF_PKGCONFIG_PRIVATE_LIBS@
++Libs.private: @LIBRDF_PKGCONFIG_PRIVATE_LIBS@
+ Cflags: -I${includedir}
+--- a/configure.ac
++++ b/configure.ac
+@@ -366,7 +366,7 @@
+ AC_MSG_RESULT($bdb_include_dir)
+
+ if test "$bdb_prefix" != no; then
+- nLDFLAGS=$LDFLAGS
++ nLDFLAGS=
+ nCPPFLAGS=
+
+ if test "$bdb_lib_dir" != /usr/lib; then
diff --git a/dev-libs/redland/redland-1.0.17-r3.ebuild b/dev-libs/redland/redland-1.0.17-r3.ebuild
new file mode 100644
index 000000000000..ad254761c6cd
--- /dev/null
+++ b/dev-libs/redland/redland-1.0.17-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit db-use libtool
+
+DESCRIPTION="High-level interface for the Resource Description Framework"
+HOMEPAGE="http://librdf.org/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb iodbc mysql odbc postgres sqlite"
+
+RDEPEND="
+ dev-libs/libltdl:0
+ mysql? ( dev-db/mysql-connector-c:0= )
+ sqlite? ( =dev-db/sqlite-3* )
+ berkdb? ( sys-libs/db:* )
+ >=media-libs/raptor-2.0.14
+ >=dev-libs/rasqal-0.9.32
+ postgres? ( dev-db/postgresql:* )
+ iodbc? ( dev-db/libiodbc )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mysql-8-my_bool.patch
+ # bug 468298
+ "${FILESDIR}"/${P}-ldflags-pc-leak.patch
+)
+
+src_prepare() {
+ default
+ elibtoolize # NOTE: this is for fbsd .so version
+}
+
+src_configure() {
+ local myconf=( --without-virtuoso )
+ if use iodbc; then
+ myconf=( --with-virtuoso --with-iodbc --without-unixodbc )
+ elif use odbc; then
+ myconf=( --with-virtuoso --with-unixodbc --without-iodbc )
+ fi
+
+ if use berkdb; then
+ myconf+=(
+ --with-bdb-include="$(db_includedir)"
+ --with-bdb-lib="${ESYSROOT}"/usr/$(get_libdir)
+ --with-bdb-dbname="$(db_libname)"
+ )
+ fi
+
+ # FIXME: upstream doesn't test with --with-threads and testsuite fails
+ econf \
+ $(use_with berkdb bdb) \
+ $(use_with mysql) \
+ $(use_with sqlite) \
+ $(use_with postgres postgresql) \
+ --without-threads \
+ --with-html-dir="${EPREFIX}"/usr/share/gtk-doc/html/ \
+ "${myconf[@]}"
+}
+
+src_test() {
+ if ! use berkdb; then
+ export REDLAND_TEST_CLONING_STORAGE_TYPE=hashes
+ export REDLAND_TEST_CLONING_STORAGE_NAME=test
+ export REDLAND_TEST_CLONING_STORAGE_OPTIONS="hash-type='memory',dir='.',write='yes',new='yes',contexts='yes'"
+ fi
+
+ default
+}
+
+src_install() {
+ HTML_DOCS=( {FAQS,NEWS,README,RELEASE,TODO}.html )
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}