summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-30 01:39:00 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-30 01:39:00 -0700
commit51074ae5c81c0b5b65952e1dbd6dadba66dfb29d (patch)
tree6cdc1be4e2c311d3c2a4f1e31311f2d6f8c4536f
parentapp-admin/logrotate: revbump for tmpfiles fix (diff)
downloadgentoo-51074ae5.tar.gz
gentoo-51074ae5.tar.bz2
gentoo-51074ae5.zip
app-admin/logrotate: drop 3.18.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-admin/logrotate/Manifest1
-rw-r--r--app-admin/logrotate/logrotate-3.18.0.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/app-admin/logrotate/Manifest b/app-admin/logrotate/Manifest
index 47c5cb3d3752..0d34971c6277 100644
--- a/app-admin/logrotate/Manifest
+++ b/app-admin/logrotate/Manifest
@@ -1,2 +1 @@
-DIST logrotate-3.18.0.tar.gz 224873 BLAKE2B f73ffa2d58a5125393e6c96e158e39e0b4cadef01e6eebd172220227a7e1363e6731bc2ac511fa028078054b55d42b131cdc30232ac5762ce4c6cbff79c19681 SHA512 d1bca267fbec4acbb83ffba4d3ac4c864f4269d8513e5614e7dbe6f3b1f176685218bffdb5d62f559ee73f84cf9a8a257c9f63e30af058d12d0034240f247586
DIST logrotate-3.18.1.tar.gz 225226 BLAKE2B 6f40dfe89f9c6202263f16204a9cff07b921abc9a298b58649bb4968c9f498626741be334c47d4092da564ed75642b687ff6ef8781f69f5e25364f8635646d9d SHA512 c40f920686aee014c652f087c64f2a85e9e866a8717d1bd3f32a9dd7959a02962e6174de28ae685428b442e12079d0c8d91485611ca34a873ffae872a54ec9fe
diff --git a/app-admin/logrotate/logrotate-3.18.0.ebuild b/app-admin/logrotate/logrotate-3.18.0.ebuild
deleted file mode 100644
index 9e712b69c695..000000000000
--- a/app-admin/logrotate/logrotate-3.18.0.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd tmpfiles
-
-DESCRIPTION="Rotates, compresses, and mails system logs"
-HOMEPAGE="https://github.com/logrotate/logrotate"
-SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="acl +cron selinux"
-
-COMMON_DEPEND="
- >=dev-libs/popt-1.5
- selinux? ( sys-libs/libselinux )
- acl? ( virtual/acl )"
-
-DEPEND="${COMMON_DEPEND}
- >=sys-apps/sed-4"
-
-RDEPEND="${COMMON_DEPEND}
- selinux? ( sec-policy/selinux-logrotate )
- cron? ( virtual/cron )"
-
-STATEFILE="/var/lib/misc/logrotate.status"
-OLDSTATEFILE="/var/lib/logrotate.status"
-
-move_old_state_file() {
- elog "logrotate state file is now located at ${STATEFILE}"
- elog "See bug #357275"
- if [[ -e "${OLDSTATEFILE}" ]] ; then
- elog "Moving your current state file to new location: ${STATEFILE}"
- mv -n "${OLDSTATEFILE}" "${STATEFILE}" || die
- fi
-}
-
-install_cron_file() {
- exeinto /etc/cron.daily
- newexe "${S}"/examples/logrotate.cron "${PN}"
-}
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.15.0-ignore-hidden.patch"
-)
-
-src_prepare() {
- sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.{cron,service} || die
- default
-}
-
-src_configure() {
- econf \
- $(use_with acl) \
- $(use_with selinux) \
- --with-state-file-path="${STATEFILE}"
-}
-
-src_test() {
- emake test
-}
-
-src_install() {
- insinto /usr
- dobin logrotate
- doman logrotate.8
- dodoc ChangeLog.md
-
- insinto /etc
- doins "${FILESDIR}"/logrotate.conf
-
- use cron && install_cron_file
-
- systemd_dounit examples/logrotate.{service,timer}
- newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
-
- keepdir /etc/logrotate.d
-}
-
-pkg_postinst() {
- elog
- elog "The ${PN} binary is now installed under /usr/bin. Please"
- elog "update your links"
- elog
- move_old_state_file
- elog "If you are running systemd you might need to run:"
- elog "systemd-tmpfiles --create /usr/lib/tmpfiles.d/logrotate.conf"
- elog "in order to create the new location of the logrotate state file"
- elog
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "If you wish to have logrotate e-mail you updates, please"
- elog "emerge virtual/mailx and configure logrotate in"
- elog "/etc/logrotate.conf appropriately"
- elog
- elog "Additionally, /etc/logrotate.conf may need to be modified"
- elog "for your particular needs. See man logrotate for details."
- fi
-}