summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 16:17:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:12 +0100
commit511d0b77bb38e6abe0a22ac0e4198a3022a54f30 (patch)
tree10dbf2752f298a23c4b0f66087ceadcab996cd11
parentdev-python/precis-i18n: Enable py3.11 (diff)
downloadgentoo-511d0b77.tar.gz
gentoo-511d0b77.tar.bz2
gentoo-511d0b77.zip
dev-python/python-nbxmpp: Bump to 3.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-nbxmpp/Manifest1
-rw-r--r--dev-python/python-nbxmpp/python-nbxmpp-3.2.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-nbxmpp/Manifest b/dev-python/python-nbxmpp/Manifest
index 87c8d8ac5248..b44217cf17f6 100644
--- a/dev-python/python-nbxmpp/Manifest
+++ b/dev-python/python-nbxmpp/Manifest
@@ -1,2 +1,3 @@
DIST python-nbxmpp-3.2.4.tar.bz2 131867 BLAKE2B bfe0fe559b62e0ba526adac810bf9ed4e491349ce8535ea6ab3d476a1b1c18accfeb450a327b1e81994f2960a475b872169a61aac67d1f16767bad18f6e5e223 SHA512 4ac1c69741b4c202c463ade601bb027f4a5442da1052e2657b1319f2b9bb6dd723033b3dcf175d655205f2e918ef1b7e3e93410fc812c847d2da7ceb48420d37
+DIST python-nbxmpp-3.2.5.tar.bz2 132029 BLAKE2B 846f3b47c3a9a95cf1fa1b557a007fd4901fb4acaa3160ea4b9b1cdff1e9d2c3e64bc5251b739d816f3f1c449c350d1ac44c14cbef87d14fe5a6450418451007 SHA512 577f8c7b0f5a7c69b4d980bff93f0a208ab0a660d731eb95ec63b76583194b94bd9d9f6b10fcac3951a6e6afb5d0c4da2140cbc17ef653f19ec6957b5d2e5f04
DIST python-nbxmpp-nbxmpp-2.0.6.tar.bz2 122203 BLAKE2B 925604002f4363f1e0b72f05c13742f4652ba565a9faa48faf8d47688f480a7f1d7585c593b0dcf07bded8c4aa3a1d02e9697742a07b9e815daec062dfb93104 SHA512 a536b25c8a6298892a51adef4b64b75ffab88ce02fb08fc07ecd1cfe2bc794262d4d58a93248439723e6e0544485da7351bb98189b0e422a1f77b01c6f6d238e
diff --git a/dev-python/python-nbxmpp/python-nbxmpp-3.2.5.ebuild b/dev-python/python-nbxmpp/python-nbxmpp-3.2.5.ebuild
new file mode 100644
index 000000000000..aaaf0919a1f4
--- /dev/null
+++ b/dev-python/python-nbxmpp/python-nbxmpp-3.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to use Jabber/XMPP networks in a non-blocking way"
+HOMEPAGE="
+ https://dev.gajim.org/gajim/python-nbxmpp/
+ https://pypi.org/project/nbxmpp/
+"
+SRC_URI="
+ https://dev.gajim.org/gajim/python-nbxmpp/-/archive/${PV}/${P}.tar.bz2
+"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ net-libs/libsoup[introspection]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest