summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 05:40:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 06:06:36 +0100
commit512ff19e82d67b7892caa8d9586e42f7e39a2f03 (patch)
tree0eecb4847f8aa0027bfd2562bb2fb73e9d5196cb
parentdev-python/pygame: Bump to 2.2.0 (diff)
downloadgentoo-512ff19e.tar.gz
gentoo-512ff19e.tar.bz2
gentoo-512ff19e.zip
dev-python/tifffile: Bump to 2023.2.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2023.2.27.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 8ca55cf87099..1120bdf05c69 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,3 +1,4 @@
DIST tifffile-2023.1.23.1.gh.tar.gz 324017 BLAKE2B ffc4a329096ac3eb44990635dea4f5d0211564d5a8847795671d3d816148721d3c6fab059514764eb45bc48c8a114382c0a1705cc606d750ef869d49e67b2c85 SHA512 fad8e2f40cc550a83030b29b528566d7b5b9cbe016c9fd04911ab4cca4e8e69523d9b17db83eee018d1ff3005cab0f36762b4a1271859b504c77a0809e07b0be
DIST tifffile-2023.2.2.gh.tar.gz 324485 BLAKE2B fb3404efa1af8197af8e3b77c2b1fbb76c215ee8d599da8974c6231b72789117edddf23072c898eb752789d789080b16106da90406a3a178388f3a863171d202 SHA512 5915374d62665d766b02d2a3c0e2f644581f3809cc650dda70feffec43151398fbbd23b2fe000be02a65fd7647e097c43c3c92482c85fe5027966038179a785f
+DIST tifffile-2023.2.27.gh.tar.gz 326444 BLAKE2B 8c5081b7434329181d5f6df416b739c43d24ff9a9c3dc2ac4b3d6d6dd5ba165290d224648e5e6b4f46bd611c85204114f8b563cb110b7b50ba73aefd0e427f2e SHA512 97ba6b6ac469e4ab92822fd51dc45ebc00776834e5b171679abed24448d5be479a06e5e401bd055a21029641668f63912246b93f15424a3b268733729515452e
DIST tifffile-2023.2.3.gh.tar.gz 324906 BLAKE2B b9417ea561de7a185f1a57a6f36a6efde12caa85cd15fd787ae1ca50e73d328f83ec6cd196042d3a11a62706ac27bfad8ecc42e0a235201ee208fdb95d942c16 SHA512 f73dd77c149afa976ac468f0fac37a1bafe35ae4bcb377a91e7922573237805cdc6e00cbcd7bb78f3213a9da4878ec020a058567523b9a4c5958e013f9bdc94b
diff --git a/dev-python/tifffile/tifffile-2023.2.27.ebuild b/dev-python/tifffile/tifffile-2023.2.27.ebuild
new file mode 100644
index 000000000000..66babf481615
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2023.2.27.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.cgohlke.com/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_5GB_bigtiff
+ tests/test_tifffile.py::test_write_5GB_fails
+ tests/test_tifffile.py::test_write_6gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+ # TODO
+ tests/test_tifffile.py::test_issue_imagej_hyperstack_arg
+ tests/test_tifffile.py::test_issue_description_overwrite
+)