summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 19:32:15 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2018-12-30 19:32:33 +0200
commit5146ffa4f45a202a5551fa987bd57ba7770c959d (patch)
tree4e775326a76f556dd116832dfb17eb9748a3423f
parentsys-apps/pcsc-lite: version bump (diff)
downloadgentoo-5146ffa4.tar.gz
gentoo-5146ffa4.tar.bz2
gentoo-5146ffa4.zip
dev-python/pyscard: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=674054 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-1.9.7.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index cb40b4c442f5..c26a5252ac0d 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-1.9.5.tar.gz 146010 BLAKE2B 04569422bef66839ab1e8420b37741ebb5591732f1b88d75d8348465d3c7758febdc5722ac0329d5722d1609abe2aaa39ce507087fd551d760f9fd0f69b06d50 SHA512 a0c5cd4ccbe8437ffd37afcf95c71f7d1d6c3ae364063cf81907095625d2062da8e7335ebfd15d1f952e8a8d9395e990b351b1308ab07fa456a7ee10658db4f9
+DIST pyscard-1.9.7.tar.gz 144692 BLAKE2B 5a842b790e01ff5461c462d6fe2d7763a79725cd1bcb841c1aaa49f2b17decb251446adb908fa8b525b91f418a6df6a76ddf779a67b7e8547211993837aed2bd SHA512 339d6efd5fcaa361e30029e736d4e2e98e05acd701c39574b40960b4bcec4782ca9c1d6927cea0b3641c5e6a137d0b9fbd961b58422a4151cfbdfa067dcd4b4a
diff --git a/dev-python/pyscard/pyscard-1.9.7.ebuild b/dev-python/pyscard/pyscard-1.9.7.ebuild
new file mode 100644
index 000000000000..f0560bcd991c
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="${PYTHON_DEP}
+ sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${PYTHON_DEP}
+ dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}