summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-18 18:02:10 +0100
committerSam James <sam@gentoo.org>2024-05-18 18:05:37 +0100
commit514d2feed3d5cabc95bf6ec13c1c410d4cb81136 (patch)
tree9c58d5038fa73427356473859e76318a1cbca110
parentsys-process/acct: drop 6.6.4-r3 (diff)
downloadgentoo-514d2feed3d5cabc95bf6ec13c1c410d4cb81136.tar.gz
gentoo-514d2feed3d5cabc95bf6ec13c1c410d4cb81136.tar.bz2
gentoo-514d2feed3d5cabc95bf6ec13c1c410d4cb81136.zip
app-misc/gcal: drop 4.1-r1, 4.1-r2
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-misc/gcal/gcal-4.1-r1.ebuild50
-rw-r--r--app-misc/gcal/gcal-4.1-r2.ebuild63
2 files changed, 0 insertions, 113 deletions
diff --git a/app-misc/gcal/gcal-4.1-r1.ebuild b/app-misc/gcal/gcal-4.1-r1.ebuild
deleted file mode 100644
index 39a20a9fc729..000000000000
--- a/app-misc/gcal/gcal-4.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="The GNU Calendar - a replacement for cal"
-HOMEPAGE="https://www.gnu.org/software/gcal/"
-SRC_URI="mirror://gnu/gcal/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="ncurses nls unicode"
-
-RDEPEND="nls? ( virtual/libintl )
- unicode? ( dev-libs/libunistring:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.17 )
-"
-
-DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
-
-PATCHES=(
- "${FILESDIR}/${P}-glibc228.patch"
- "${FILESDIR}/${PN}-4.1-configure-clang16.patch"
-)
-
-src_prepare() {
- default
-
- # Drop once ${PN}-4.1-configure-clang16.patch merged
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- append-cppflags -D_GNU_SOURCE
-
- use unicode && append-libs -lunistring
-
- econf \
- --disable-rpath \
- $(use_enable nls) \
- $(use_enable ncurses term) \
- $(use_enable unicode)
-}
diff --git a/app-misc/gcal/gcal-4.1-r2.ebuild b/app-misc/gcal/gcal-4.1-r2.ebuild
deleted file mode 100644
index 55f7fafd8d71..000000000000
--- a/app-misc/gcal/gcal-4.1-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic toolchain-funcs
-
-DESCRIPTION="The GNU Calendar - a replacement for cal"
-HOMEPAGE="https://www.gnu.org/software/gcal/"
-SRC_URI="mirror://gnu/gcal/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="ncurses nls unicode"
-
-RDEPEND="nls? ( virtual/libintl )
- unicode? ( dev-libs/libunistring:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/xz-utils
- nls? ( >=sys-devel/gettext-0.17 )
-"
-
-DOCS=( BUGS LIMITATIONS NEWS README THANKS TODO )
-
-PATCHES=(
- "${FILESDIR}/${P}-glibc228.patch"
- "${FILESDIR}/${PN}-4.1-configure-clang16.patch"
- "${FILESDIR}/${P}-fortify.patch"
-)
-
-src_prepare() {
- default
-
- # Drop once ${PN}-4.1-configure-clang16.patch merged
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
- append-cppflags -D_GNU_SOURCE
-
- use unicode && append-libs -lunistring
-
- econf \
- --disable-rpath \
- $(use_enable nls) \
- $(use_enable ncurses term) \
- $(use_enable unicode)
-}
-
-src_test() {
- default
-
- # Do basic smoke tests to help catch issues like bug #925560
- # where trivial 'gcal' invocation crashed w/ _F_S=3.
- local -x PATH="${S}/src:${S}:${PATH}"
- local bin
- for bin in gcal2txt tcal txt2gcal gcal ; do
- src/${bin} || die
- done
-}