summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-09 09:45:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-09 15:58:32 +0100
commit51558712d1096d36d2328f7acda14a702227a818 (patch)
tree91bfc5f7ee585dc6e596c79255d3e89f14b40e00
parentsys-libs/libcxx: Bump to 6.0.0 final (diff)
downloadgentoo-51558712d1096d36d2328f7acda14a702227a818.tar.gz
gentoo-51558712d1096d36d2328f7acda14a702227a818.tar.bz2
gentoo-51558712d1096d36d2328f7acda14a702227a818.zip
sys-libs/libomp: Bump to 6.0.0 final
-rw-r--r--sys-libs/libomp/Manifest2
-rw-r--r--sys-libs/libomp/libomp-6.0.0.ebuild (renamed from sys-libs/libomp/libomp-6.0.0_rc3.ebuild)8
2 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/libomp/Manifest b/sys-libs/libomp/Manifest
index cb0b3d4b27b5..f909daa01d14 100644
--- a/sys-libs/libomp/Manifest
+++ b/sys-libs/libomp/Manifest
@@ -4,4 +4,4 @@ DIST openmp-3.9.0.src.tar.xz 2257596 BLAKE2B fae0e3e36afcd1a223030f09209865ce706
DIST openmp-3.9.1.src.tar.xz 2031588 BLAKE2B feafb94a832ec48a67d6e00720724dcecb533a4a09e0d69462af33e13454b20393aa21fabb062c362824cdfbee712db1030732271e4cd49085fa69cff9800835 SHA512 80924a6f9765f634d24d7b0aa036d92c912dbd8e067487a14bdd03b4c587fdfc92e83eb29926bfa637ef45be3f133a924f77ab12099ea3706c18e9c42774708b
DIST openmp-4.0.1.src.tar.xz 2275240 BLAKE2B e63cf670c4cd2678afc4d7b96be85c3d157bf91a69510f980d9a0a07f61b449b22ff28d63753f32e63afedb4a7077c662a633f689a660b5047a83bcf1fb7f009 SHA512 0b737dde832c5907a0cac41fe1d594b61e85dd405eee42b39f09233db62b44543204ccc775e52e2981f9c9f0683b234526e288a3a7a04f712280fb3a575abcaf
DIST openmp-5.0.1.src.tar.xz 2075472 BLAKE2B a4da4726a17dc0fd083e11fe1bebf446978137aa4453000e8fea950021fff091a818246f0817dd60ce67353d3f7d75ab8fec2b9e955389d9c94e195945efda50 SHA512 4493b918fd83ef26e2b3f3429d1b00d722328e4c9697ac7625a390834f6e88ada8e5b02ce0ecb4771129207b1b81a9d171f4599ab9388762a3c6db0afc499ff4
-DIST openmp-6.0.0rc3.src.tar.xz 2272612 BLAKE2B aaa8cf979c98459c23d0dacf6dc8630ea7adb0eef815e99188034b6f01e46c5ab78274f69b7ab3ea3e8f66b4192b7d02fc448b0f32c27c5336e8dafc9adc5bb6 SHA512 0c4407821b6e5a0f89fa69c81ba891f641d0cadd1fecc4712e488a4e040ecccb84e825a774d0e660d5cc41962d3b3a10084085b556c73f4d4eb48979b1a7069a
+DIST openmp-6.0.0.src.tar.xz 2272360 BLAKE2B 2fbbdbbd0262ac3161446a4e7a3079131254f962a5397a94913abff024ba3f66affe419c58fb0f6ab602e338a277ab2befbc4386eaf6d4c11aa4a9713315d562 SHA512 9dfb070a3fae883985e3c8cd357c21a2144b433824139e288d4d3c774dd9cf3f7949978976012b08c644cd4a04be8c65a810c2f33d66eee05d3d980e61413a06
diff --git a/sys-libs/libomp/libomp-6.0.0_rc3.ebuild b/sys-libs/libomp/libomp-6.0.0.ebuild
index 98935fa8fbc4..13b505e856c5 100644
--- a/sys-libs/libomp/libomp-6.0.0_rc3.ebuild
+++ b/sys-libs/libomp/libomp-6.0.0.ebuild
@@ -8,11 +8,11 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-multilib linux-info python-any-r1
+inherit cmake-multilib linux-info multiprocessing python-any-r1
DESCRIPTION="OpenMP runtime library for LLVM/clang compiler"
HOMEPAGE="https://openmp.llvm.org"
-SRC_URI="http://prereleases.llvm.org/${PV/_//}/openmp-${PV/_/}.src.tar.xz"
+SRC_URI="https://releases.llvm.org/${PV/_//}/openmp-${PV/_/}.src.tar.xz"
# Additional licenses:
# - MIT-licensed Intel code,
@@ -20,7 +20,7 @@ SRC_URI="http://prereleases.llvm.org/${PV/_//}/openmp-${PV/_/}.src.tar.xz"
LICENSE="|| ( UoI-NCSA MIT ) MIT LLVM-Grant"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x64-macos"
IUSE="cuda hwloc kernel_linux offload ompt test"
# CUDA works only with the x86_64 ABI
REQUIRED_USE="offload? ( cuda? ( abi_x86_64 ) )"
@@ -99,7 +99,7 @@ multilib_src_configure() {
use test && mycmakeargs+=(
# this project does not use standard LLVM cmake macros
-DOPENMP_LLVM_LIT_EXECUTABLE="${EPREFIX}/usr/bin/lit"
- -DOPENMP_LIT_ARGS="-vv"
+ -DOPENMP_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DOPENMP_TEST_C_COMPILER="$(type -P "${CHOST}-clang")"
-DOPENMP_TEST_CXX_COMPILER="$(type -P "${CHOST}-clang++")"