summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-14 18:57:21 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-14 19:00:05 -0700
commit51564faa4dfefe84e7b9def184ab105823beaf88 (patch)
tree4b6e9a68e39f9768bab39c3dfcc14b8745bda547
parentgo-module.eclass: fix eclassdoc @DEPRECATION tags (diff)
downloadgentoo-51564faa4dfefe84e7b9def184ab105823beaf88.tar.gz
gentoo-51564faa4dfefe84e7b9def184ab105823beaf88.tar.bz2
gentoo-51564faa4dfefe84e7b9def184ab105823beaf88.zip
sys-devel/sparse: Depend on x11-libs/gtk+:3, not :2
Upstream commit 52ac1749 ("test-inspect: Detect gtk3 then gtk2 package") in 2017 changed the default to GTK 3 and we didn't notice apparently. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sys-devel/sparse/metadata.xml2
-rw-r--r--sys-devel/sparse/sparse-0.6.4-r1.ebuild (renamed from sys-devel/sparse/sparse-0.6.4.ebuild)4
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/sparse/metadata.xml b/sys-devel/sparse/metadata.xml
index aec196782c68..4eec8f82d259 100644
--- a/sys-devel/sparse/metadata.xml
+++ b/sys-devel/sparse/metadata.xml
@@ -10,7 +10,7 @@
<name>Gentoo Toolchain Project</name>
</maintainer>
<use>
- <flag name="gtk">Build the test-inspect utility (requires <pkg>x11-libs/gtk+</pkg> version 2)</flag>
+ <flag name="gtk">Build the test-inspect utility (requires <pkg>x11-libs/gtk+</pkg>:3)</flag>
<flag name="llvm">Build the sparse-llvm utility</flag>
<flag name="xml">Build the c2xml utility (requires <pkg>dev-libs/libxml2</pkg>)</flag>
</use>
diff --git a/sys-devel/sparse/sparse-0.6.4.ebuild b/sys-devel/sparse/sparse-0.6.4-r1.ebuild
index 6fbcc28e1552..a7c5b9dbc728 100644
--- a/sys-devel/sparse/sparse-0.6.4.ebuild
+++ b/sys-devel/sparse/sparse-0.6.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="gtk llvm sqlite test xml"
RESTRICT="!test? ( test )"
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
+RDEPEND="gtk? ( x11-libs/gtk+:3 )
llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
sqlite? ( dev-db/sqlite:= )
xml? ( dev-libs/libxml2 )"
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index 6fbcc28e1552..a7c5b9dbc728 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ SLOT="0"
IUSE="gtk llvm sqlite test xml"
RESTRICT="!test? ( test )"
-RDEPEND="gtk? ( x11-libs/gtk+:2 )
+RDEPEND="gtk? ( x11-libs/gtk+:3 )
llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
sqlite? ( dev-db/sqlite:= )
xml? ( dev-libs/libxml2 )"