summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2022-05-16 08:55:18 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-26 15:58:03 +0300
commit515cc76f5260325a86ce3048565185c7ebf8b385 (patch)
treea309ca3fe4cbff70d281bb3d08f0f704d3a70d9c
parentapp-misc/elasticsearch: update acct-* deps to be DEPEND from BDEPEND (diff)
downloadgentoo-515cc76f5260325a86ce3048565185c7ebf8b385.tar.gz
gentoo-515cc76f5260325a86ce3048565185c7ebf8b385.tar.bz2
gentoo-515cc76f5260325a86ce3048565185c7ebf8b385.zip
mail-client/alpine: update Chappa patch to the latest version
Bug: https://bugs.gentoo.org/844052 Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/25522 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.25-r2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index fe1c60aab398..c0e22786c7d9 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,3 +1,4 @@
+DIST alpine-2.25-chappa-11.patch.gz 172996 BLAKE2B b6fe190d8f95ffa9d851d4760517c25262645e1b52bcdeee75f36fc16f4ae6da862e60b144a9a037a9544e4910ce2cba39ff6f311a7a7254de18fd604453ef3d SHA512 c99c511bae13fe991fddeddedce13a0f538f7422eccf7f326db8f7d1a5558023c9995c595ec1b83f188f218894b16011ea0990797c0ab056ed7d5da600e9c518
DIST alpine-2.25-chappa.patch.gz 172963 BLAKE2B 5e306325beb46fd2f716620794894f563b93e116693a1af050ea5f61c203350d2aa72b67d7f66acc748caea6a73bdef85f45324eb01edf8a6035b07f8a50e2bb SHA512 b88ca58e42a72b2b92cf28e4cae492a5ee75d534821046645fcc358833e87287fc707d5bec5c3508942a0ef1ecffe64916f00f1a01e430048384838e5ca40358
DIST alpine-2.25-ssl.patch 5431 BLAKE2B 0cf2fcb682fbee41aa988ff089c16b75ebd9bee321c1c130d0b5136e5ca521bded7e9a97cd3ade1c86b17e72136264d4405cc36427a347c9bee84ee8a64548d4 SHA512 698d2a3c3b7b588fe3fcfe0291f0aab05c42b5ea80de1f210c1985082651329b80447de4e8057bc7e962fe8ed5175ea8132bad413c02fb1f0cc67c84e9420642
DIST alpine-2.25.tar.xz 7495372 BLAKE2B ce2587a309c87ba527d51c360ee0d9627453cce6585631f569eb26db04aa6c5cddb7c9599478092447a040c43e9234e78a942fef4b1186d07c608163f96236be SHA512 76c214cf66f4ac7af3de40357ad3a592ff2a119e327e5f6c256125b7865d46b09197435fe6ac8077ab7a498e4821925939f3f902431ca77baa786e149466a193
diff --git a/mail-client/alpine/alpine-2.25-r2.ebuild b/mail-client/alpine/alpine-2.25-r2.ebuild
new file mode 100644
index 000000000000..482680e82344
--- /dev/null
+++ b/mail-client/alpine/alpine-2.25-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa-11.patch"
+SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz
+ https://repo.or.cz/alpine.git/patch/fb2217ac67706e4cbef69bea41041e2fb8b910e9 -> ${P}-ssl.patch
+ chappa? ( http://alpine.x10host.com/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+chappa ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads"
+
+# alpine-2.25-ssl.patch can only be applied when not using the chappa patches.
+REQUIRED_USE="chappa? ( ssl )"
+
+DEPEND="sys-libs/ncurses:=
+ virtual/libcrypt:=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap:= )
+ spell? ( app-text/aspell )
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ if use !ssl; then
+ eapply "${DISTDIR}/${P}-ssl.patch"
+ fi
+ use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_with threads pthread)
+ $(use_with spell interactive-spellcheck /usr/bin/aspell)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR="$(tc-getAR)"
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+ dodoc NOTICE README*
+ dodoc doc/brochure.txt
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+}