summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 14:57:02 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2016-01-12 15:51:10 -0500
commit517ec9707fcac94595e8efba10a04e15f9f8954a (patch)
tree01b1d40cb26a83d4df757bd611769639fc5c7e44
parentgames-fps/ut2003-bonuspack-de: EAPI=5 (diff)
downloadgentoo-517ec9707fcac94595e8efba10a04e15f9f8954a.tar.gz
gentoo-517ec9707fcac94595e8efba10a04e15f9f8954a.tar.bz2
gentoo-517ec9707fcac94595e8efba10a04e15f9f8954a.zip
games-fps/ut2003-bonuspack-epic: EAPI=5
Package-Manager: portage-2.2.26
-rw-r--r--games-fps/ut2003-bonuspack-epic/Manifest2
-rw-r--r--games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild43
2 files changed, 19 insertions, 26 deletions
diff --git a/games-fps/ut2003-bonuspack-epic/Manifest b/games-fps/ut2003-bonuspack-epic/Manifest
index 4ab497a00028..bd480864f022 100644
--- a/games-fps/ut2003-bonuspack-epic/Manifest
+++ b/games-fps/ut2003-bonuspack-epic/Manifest
@@ -1 +1 @@
-DIST UT2003-epicbonuspackone.exe 156913152 RMD160 5faf4028ef7178c964cb913f80bf56f77a5b3c00 SHA1 f4a475dc3bbbbebbf125a6dac74bc01bd74515ef SHA256 034a1641c447e2d933ae89e02fecdd2c0358d041dcf3f7996663aaf6901cee21
+DIST UT2003-epicbonuspackone.exe 156913152 SHA256 034a1641c447e2d933ae89e02fecdd2c0358d041dcf3f7996663aaf6901cee21 SHA512 26fa06637c6a99704d11b58f5fe54454f8018c6f07b06b6a9a2075d17b9a9fb7d7155298de5502cefa0f07995f4513ce9531863cef8c344996b5e6dd5fbd339d WHIRLPOOL 681311f3515b0d3e266159d5ceeb76120567e1f90bef2e1da124aa8b54865caee5d86ae3ff5a2272f29922bf66378bb9f22c65eaf80fa1d414d34b9e899d0acb
diff --git a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
index 0544e3aaf3d5..7b5d4ec9a188 100644
--- a/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
+++ b/games-fps/ut2003-bonuspack-epic/ut2003-bonuspack-epic-1.ebuild
@@ -2,17 +2,18 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
inherit games
-IUSE=""
DESCRIPTION="Epic Bonus Pack for UT2003"
-HOMEPAGE="http://www.unrealtournament2003.com/"
-SRC_URI="UT2003-epicbonuspackone.exe"
+HOMEPAGE="http://www.moddb.com/games/unreal-tournament-2003"
+SRC_URI="http://ftp.student.utwente.nl/pub/games/UT2003/BonusPack/UT2003-epicbonuspackone.exe"
LICENSE="ut2003"
SLOT="1"
KEYWORDS="x86"
-RESTRICT="fetch strip"
+IUSE=""
+RESTRICT="strip"
DEPEND="app-arch/unzip"
RDEPEND="games-fps/ut2003"
@@ -22,31 +23,23 @@ S=${WORKDIR}/UT2003-BonusPack
dir=${GAMES_PREFIX_OPT}/ut2003
Ddir=${D}/${dir}
-pkg_nofetch() {
- einfo "Please download ${A} and put it into ${DISTDIR}"
- einfo "http://files.filefront.com/ut2003+epicbonuspackoneexe/;826445;/fileinfo.html"
-}
-
src_unpack() {
- unzip -qq "${DISTDIR}"/${A} || die "unpacking"
+ unzip -qq "${DISTDIR}"/${A} || die
# This is done since the files are the same
- rm -f "${S}"/Textures/LastManStanding.utx
+ rm -f "${S}"/Textures/LastManStanding.utx || die
}
src_install() {
insinto "${dir}"/Help
- newins "${S}"/Help/BonusPackReadme.txt EpicBonusPack.README || die "README"
+ newins "${S}"/Help/BonusPackReadme.txt EpicBonusPack.README
exeinto "${dir}"
doexe "${FILESDIR}"/epic-installer
dodir "${dir}"/System
- cp -r "${S}"/{Maps,Sounds,StaticMeshes,Textures} "${Ddir}" \
- || die "Copying Maps/Sounds/Textures"
- cp "${S}"/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} \
- "${Ddir}"/System || die "Copying System files"
- cp -v "${S}"/System/Manifest.ini "${Ddir}"/System/Manifest.ini.epic \
- || die "Copying Manifest"
+ cp -r "${S}"/{Maps,Sounds,StaticMeshes,Textures} "${Ddir}" || die
+ cp "${S}"/System/{*.{det,est,frt,int,itt,kot,tmt,u},User.ini} "${Ddir}"/System || die
+ cp -v "${S}"/System/Manifest.ini "${Ddir}"/System/Manifest.ini.epic || die
prepgamesdirs
}
@@ -65,11 +58,11 @@ pkg_postinst() {
}
pkg_config() {
- cd ${dir}/System
- cp Manifest.ini Manifest.ini.pre-epic
- cp ${dir}/System/Manifest.ini.epic Manifest.ini
+ cd ${dir}/System || die
+ cp Manifest.ini Manifest.ini.pre-epic || die
+ cp ${dir}/System/Manifest.ini.epic Manifest.ini || die
- cp Default.ini Default.ini.pre-epic
+ cp Default.ini Default.ini.pre-epic || die
cat >> Default.ini <<EOT
[Xinterface.Tab_AudioSettings]
@@ -112,7 +105,7 @@ w
q
EOT
- cp DefUser.ini DefUser.ini.pre-epic
- sed -i 's/^F11=.*$/F11=MusicMenu/g' DefUser.ini
- chown games:games ${dir}/System/*.ini
+ cp DefUser.ini DefUser.ini.pre-epic || die
+ sed -i 's/^F11=.*$/F11=MusicMenu/g' DefUser.ini || die
+ chown games:games ${dir}/System/*.ini || die
}