summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-27 23:23:06 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-27 23:23:53 +0200
commit518b643fd03ffa56522bd0e1541ceb1465bc63a7 (patch)
treede08d21fff37c6257f6ba649a107941204536434
parentsys-power/bbswitch: Fix compat with kernel 5.18 (diff)
downloadgentoo-518b643fd03ffa56522bd0e1541ceb1465bc63a7.tar.gz
gentoo-518b643fd03ffa56522bd0e1541ceb1465bc63a7.tar.bz2
gentoo-518b643fd03ffa56522bd0e1541ceb1465bc63a7.zip
sys-power/bbswitch: drop 0.8_p20200526
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-power/bbswitch/Manifest1
-rw-r--r--sys-power/bbswitch/bbswitch-0.8_p20200526.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/sys-power/bbswitch/Manifest b/sys-power/bbswitch/Manifest
index 97f834f76331..959fb69350c2 100644
--- a/sys-power/bbswitch/Manifest
+++ b/sys-power/bbswitch/Manifest
@@ -1,2 +1 @@
-DIST bbswitch-0.8_p20200526.tar.gz 15869 BLAKE2B cdeaf539a0996f53d3add215fca1127321b7183526a248340177f4320171b92a5ce531eeedfb1da2f0d9f07c6b61e8cfb635a457406e477640f2e7090b29b655 SHA512 487bcd845d1f462e77b5b9e3f304cd28d0ddfd391ecc36de530a3d18d9d4932bc895ed29972e27006b6f3eeb50c37b523ef786a26b6ee75c19fa55288a496d4a
DIST bbswitch-0.8_p20211129.tar.gz 15889 BLAKE2B f81343529957603734bc29453ae9513eb5e19a87425adb8975c621357c7caa0f353e06367cc186230adb28f75ae48330a58ba904854415bc118c8573f71566a0 SHA512 e7873ae34aed13e8f4d5709fede763552c28528e853ad02ee4a4377c043f1ce2ae5f7fc3e831ea1dc65f5a1c0a5ddded93b451258b539ed72b0e1c196676a677
diff --git a/sys-power/bbswitch/bbswitch-0.8_p20200526.ebuild b/sys-power/bbswitch/bbswitch-0.8_p20200526.ebuild
deleted file mode 100644
index 62367166d15b..000000000000
--- a/sys-power/bbswitch/bbswitch-0.8_p20200526.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Bumblebee-Project/${PN}.git"
- EGIT_BRANCH="develop"
-else
- COMMIT="ddbd243638c7bc2baecf43a78aff46cdc12e9b2e"
- SRC_URI="https://github.com/Bumblebee-Project/bbswitch/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
- S="${WORKDIR}/bbswitch-${COMMIT}"
-fi
-
-DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
-HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
-
-SLOT="0"
-LICENSE="GPL-3+"
-IUSE=""
-
-DEPEND="
- virtual/linux-sources
- sys-kernel/linux-headers
-"
-RDEPEND=""
-
-MODULE_NAMES="bbswitch(acpi)"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- BUILD_TARGETS="default"
- BUILD_PARAMS="KVERSION=${KV_FULL} CC=$(tc-getCC)"
-}
-
-src_prepare() {
- # Fix build failure, bug #513542 and bug #761370
- sed "s%^KDIR :=.*%KDIR := ${KV_OUT_DIR:-$KERNEL_DIR}%g" -i Makefile || die
-
- default
-}
-
-src_install() {
- einstalldocs
-
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
-
- linux-mod_src_install
-}