summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-09 21:21:04 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-09 21:24:26 +0100
commit5196175cbd53d5ba99084c0eed81a0959bf25cf4 (patch)
treed24676966da430f879572107bd208e5b9b9586e2
parentmedia-libs/alsa-lib: Bump to version 1.2.6.1 (diff)
downloadgentoo-5196175cbd53d5ba99084c0eed81a0959bf25cf4.tar.gz
gentoo-5196175cbd53d5ba99084c0eed81a0959bf25cf4.tar.bz2
gentoo-5196175cbd53d5ba99084c0eed81a0959bf25cf4.zip
net-dns/nsd: Bump to version 4.3.9
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/nsd-4.3.9.ebuild117
2 files changed, 118 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 99ae03860086..76232e7c9853 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,2 +1,3 @@
DIST nsd-4.3.7.tar.gz 1221215 BLAKE2B 79bd49324f62812a7f0f5800a686d09600620d1dc87ed9e7d4c1f2822c68700b73f5c58c328927fdf7f4af61a401033e39a8e59e054e53c564acfefc86d68bde SHA512 ef5fbcbeccba7e90cc7eed32c6a6f61f5471e13bfb74e5dd072cc9be7af67ebf97c93c0902e115efeda89489399e0543566a6847788ea7bebf13b9007f2c6193
DIST nsd-4.3.8.tar.gz 1225840 BLAKE2B 19d014f130844aab5b7c6224658c6e5a4a7d8d337ceb11e1641bceb367fe76b46be146c703296a12cec834020992eabec0e1ee8f3cb6211333ac8c4c7029fef5 SHA512 aec892f85a6757bfdf537c6f0b4bc3d60c564b3062b582af14df800b24261edc96bedcd0b6649444a46b198b9018397e356b919a871364032c8a2db6256b9268
+DIST nsd-4.3.9.tar.gz 1222919 BLAKE2B 0b317c246f66476e95727d763bf7444cde14936c8a87036843458b89f8c79790130995db3f0f9ff33d8bfda756cf3ae4724b07f97ee2996f05a2dcd1c14bc0e5 SHA512 de170cbaf6e0be0a20941d9d6b2102a7dddb59a320c30566238447d5740e4497f751f54488f36c2b89f2c3cff6e3101df31a36d0d2d66db8d77cfb6e86124f32
diff --git a/net-dns/nsd/nsd-4.3.9.ebuild b/net-dns/nsd/nsd-4.3.9.ebuild
new file mode 100644
index 000000000000..77567aaed614
--- /dev/null
+++ b/net-dns/nsd/nsd-4.3.9.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ # Required to get correct pkg-config macros with USE="systemd"
+ # see bugs #663618 and #758050
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}