summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-03-13 09:31:21 -0700
committerZac Medico <zmedico@gentoo.org>2019-03-13 09:32:32 -0700
commit51b9f6031553de20c5e706cc9fd1d2a5da4f190d (patch)
treeeefd726635ca9552f96e185dab6d8cbc8c557e87
parentnet-libs/davix: bump to 0.7.2 (diff)
downloadgentoo-51b9f603.tar.gz
gentoo-51b9f603.tar.bz2
gentoo-51b9f603.zip
app-emulation/buildah: version bump to 1.7.1
Reported-by: Dennis Schridde <devurandom@gmx.net> Closes: https://bugs.gentoo.org/680222 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.7.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index 028110d26d54..8a816aa13666 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -3,4 +3,5 @@ DIST buildah-1.3.tar.gz 4486873 BLAKE2B 35fb62626d2466495da47579cf4ab23603797ef4
DIST buildah-1.4.tar.gz 4529960 BLAKE2B 20878d322d75c6c7c2921f91a9d5434231456d2e6a94c1d4b9ca4fc068bcde1359ba0113dbf97c05738e328933068cbe2a101a1fb429e602533a42a94282a840 SHA512 8b7fc6e94da3615ce42a13621f766602465404f30c7e4e0fcb50998aefb59ebd50a4e000b8b3887e150656a2dd8b8fb3541991f8cac1193322e828448b89056d
DIST buildah-1.5.tar.gz 4549438 BLAKE2B 0b547f2e06a012540e633e3e55d12d5f44141be7e7231643efd1914571b0d3b03411b5d95f2b8e616679c1f8c966fda818ac8d2a2ca016e89218480ca1c9392c SHA512 291bf7d174500e96279f7fba143f72349648b09fd2d100e6409ae75c8436ff323143ed5b8b1a3448865171916bd44790292344247f0579c33a72c1ff774631e5
DIST buildah-1.6.tar.gz 6296936 BLAKE2B 1c5e0b1a8d3f3be381c0b7cad5c52af95ee8977c46500e24888bda3f33fffead493b53deb6bbec879d342639fbaab69acbbf0186d7794f6261b3a81b958475e9 SHA512 fb946351602370ecadce84bddde9b8c954b5ecd1ed88f75db8335bf3b5cb0fc68b90a253433d51ddab04d32a6ec2e87d48282f51ec2c3965410533f1247e96f0
+DIST buildah-1.7.1.tar.gz 5048407 BLAKE2B e76cbc95ce835eaa26d53f6ce74b9bbb0d4d5683f91bdaf090158ffdc3d223a522a825af2d99d573a5c3cd57445b4d7c3d4aff359454beac81244821367ab3d7 SHA512 4b62a604dcae7a8fd0a1d74186c6f5d4a5288072b014d51d929f68442436e774428b99e62a78504314cbec517254f29d79294dc6c0b30a999788c9af12d0be01
DIST buildah-1.7.tar.gz 5041530 BLAKE2B 5a30cd75783448cfc0df8167406669c1b687781e819513c11d2941087aa4ccc1b87f10acc6e4a77de5dc991435640aefd6139ee9bb66e5952de63d1593b6fab9 SHA512 fb44787b59c4ba26bc9b38ba434c6eeebbdeeeb3d28d44819bfe05c42e1a8db63e41d75382d8f25c2c72b44c7512dd5f5b7f3e4838afa40fb67037616594f8c0
diff --git a/app-emulation/buildah/buildah-1.7.1.ebuild b/app-emulation/buildah/buildah-1.7.1.ebuild
new file mode 100644
index 000000000000..b70628774159
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.7.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ostree selinux"
+EGO_PN="${HOMEPAGE#*//}"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="93747b1"
+SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+REQUIRED_USE="!selinux? ( !ostree )"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+ default
+ sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
+
+ [[ -f ostree_tag.sh ]] || die
+ use ostree || { echo -e "#!/bin/sh\necho containers_image_ostree_stub" > \
+ ostree_tag.sh || die; }
+
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ env -u GOCACHE -u XDG_CACHE_HOME GOPATH="${WORKDIR}/${P}" emake all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ GOPATH="${WORKDIR}/${P}" emake test-unit
+}