summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-27 13:02:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-27 13:02:12 +0200
commit51be03eb6776b8f26e1c7a24fc3b4b52d99b76f2 (patch)
treeea9c7fa43f2ad6c70b21355ba2f5adfc4a7dcd34
parentdev-python/zeroconf: Stabilize 0.132.2 x86, #930772 (diff)
downloadgentoo-51be03eb6776b8f26e1c7a24fc3b4b52d99b76f2.tar.gz
gentoo-51be03eb6776b8f26e1c7a24fc3b4b52d99b76f2.tar.bz2
gentoo-51be03eb6776b8f26e1c7a24fc3b4b52d99b76f2.zip
dev-python/build: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/build/Manifest1
-rw-r--r--dev-python/build/build-1.2.0.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/build/Manifest b/dev-python/build/Manifest
index 75c88e83f845..870963f6d9b7 100644
--- a/dev-python/build/Manifest
+++ b/dev-python/build/Manifest
@@ -1,3 +1,2 @@
DIST build-1.1.1.gh.tar.gz 44605 BLAKE2B aa1d554d55007e8cb715981938bb8765230ae5ddc6c5bc29efeb52c0e18b6337a13c27f3389772a83cc0ecc9b7d3e889fbc305e91f1290424d7031a1782f683f SHA512 5fa64b07f2c22faca074d1447f5fcb12b7ad40e5fe897f034901d7932d8a9aa2c1dfa806d373503246255d7d9a2429b336384a980376f4ae7c810ae275b735da
-DIST build-1.2.0.gh.tar.gz 47350 BLAKE2B 874f4871d5b8c22ce1d93a840fd00315cfa3a93b01a44e3c8c3270d2dcb66455e2c44e757d0ae15a58a35ea4ee8679a797191523254c914150d801cf3c0a5fa8 SHA512 aaa4677f8eb04c2872dc0f64287e00cd0aa47b10d3bfd67a63c22db42caef8baae9996c3a6ced3a07cce4a54d6fd52a3f15d167f804f7f518d258aa5da68419c
DIST build-1.2.1.gh.tar.gz 47394 BLAKE2B d38a138dee5065ff0faee453bdc608fc519bc4b4a3cec8b60cf4f745288f8238dd7e9334f75bdd67765037a62b220079ce924c6581f745eb3750e732b2184d48 SHA512 77003e16d3776c3a4be920251bf14650eea112b92d94116cb1893195b8e16aae57321206ae63267119247f2794f220c891b7d913e07a8258b313d34c07d54fe9
diff --git a/dev-python/build/build-1.2.0.ebuild b/dev-python/build/build-1.2.0.ebuild
deleted file mode 100644
index 92cc73481513..000000000000
--- a/dev-python/build/build-1.2.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple, correct PEP517 package builder"
-HOMEPAGE="
- https://pypi.org/project/build/
- https://github.com/pypa/build/
-"
-SRC_URI="
- https://github.com/pypa/build/archive/${PV}.tar.gz -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc64 ~sparc"
-IUSE="test-rust"
-
-RDEPEND="
- >=dev-python/packaging-19.1[${PYTHON_USEDEP}]
- dev-python/pyproject-hooks[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/filelock-3[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2[${PYTHON_USEDEP}]
- >=dev-python/pytest-rerunfailures-9.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-1.34[${PYTHON_USEDEP}]
- >=dev-python/setuptools-56.0.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
- test-rust? (
- !sparc? ( dev-python/uv )
- )
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # broken by the presence of flit_core
- tests/test_util.py::test_wheel_metadata_isolation
- # broken by the presence of virtualenv (it changes the error
- # messages, sic!)
- 'tests/test_main.py::test_output[via-sdist-isolation]'
- 'tests/test_main.py::test_output[wheel-direct-isolation]'
- # broken when built in not normal tty on coloring
- tests/test_main.py::test_colors
- 'tests/test_main.py::test_output_env_subprocess_error[color]'
- # Internet
- 'tests/test_main.py::test_verbose_output[False-0]'
- 'tests/test_main.py::test_verbose_output[False-1]'
- )
-
- if ! has_version ">=dev-python/uv-0.1.18"; then
- EPYTEST_DESELECT+=(
- tests/test_env.py::test_external_uv_detection_success
- tests/test_env.py::test_uv_impl_install_cmd_well_formed
- 'tests/test_env.py::test_venv_creation[uv-venv+uv-None]'
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m "not network" -p pytest_mock -p rerunfailures
-}